更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 970|回复: 10
收起左侧

用易语言与Gif Movie Gear设计制作精品透明Logo - 绝不用PS等软件

[复制链接]
回帖奖励 20 枚从币 回复本帖可获得 10 枚从币奖励! 每人限 1 次(中奖概率 80%)
发表于 2018-5-5 10:42:08 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x
需要软件:
Gif Movie Gear (编辑图片透明用,不需要透明的可以不要)
易语言最新版本
Discuz! X 系列论坛(可选)
模块源码:
位图增强模块         (位图处理增强)
txt转bmp         (用于生成英文点阵字体)
站内搜索下载

用一种颜色作为透明底色,我用的是黑色,但这个颜色绝对不能在前景色中出现。

按照以下方法,生成一段字母数字,如下图所示:

代码1.png
结果1.png

新建一个窗口程序,选择无边框,尺寸按照网页上的logo尺寸进行 (首页logo通常为129x66)。
放置一个图片框,宽高为刚才生成的图片尺寸,并右键横向居中。

重复以上步骤,生成商标图案,源码自行修改。
代码2.png
生成以后,将Logo放置到合适位置,粘贴以下代码:
代码3.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 窗口程序集_启动窗口

  4. .子程序 __启动窗口_创建完毕

  5. 可视 = 真
  6. 延迟 (100)
  7. 写到文件 (“logo.bmp”, 快照 (取窗口句柄 (), 宽度, 高度))
  8. 结束 ()
复制代码


运行后,生成logo.bmp 文件,用画图另存为png格式。
用GIF Movie Gear打开logo.png 设置透明底色,选择黑色保存即可,如下图所示:
设置透明底色.png
将logo.png 上传至论坛的 static/image/common/ 目录下并覆盖即可。
制作结果.png

相关帖子

回复

使用道具 举报

发表于 2018-5-5 11:06:08 | 显示全部楼层
本帖最后由 520 于 2018-5-5 11:08 编辑

沙发,比ps简单多了
回复 支持 反对

使用道具 举报

发表于 2018-5-13 20:29:58 | 显示全部楼层

回帖奖励 +10 枚从币

不错,正好需要
回复 支持 反对

使用道具 举报

发表于 2018-6-13 22:03:15 | 显示全部楼层
这个方法都可以,666
回复 支持 反对

使用道具 举报

发表于 2018-10-12 23:55:34 | 显示全部楼层

回帖奖励 +10 枚从币

原来酱紫的简单,谢谢分享
回复 支持 反对

使用道具 举报

发表于 2019-3-19 23:11:25 | 显示全部楼层

回帖奖励 +10 枚从币

又学会了1照,棒棒哒???
回复 支持 反对

使用道具 举报

发表于 2019-4-17 09:05:20 | 显示全部楼层

回帖奖励 +10 枚从币

顶顶顶顶顶
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则