免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 113|回复: 1
收起左侧

易语言置入代码通过自定义子程序指针处理文本型字符串 (每1个字节进行运算 返回0终止)

[复制链接]
发表于 2019-4-3 10:31:38 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 文本, 文本型

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 文本 = “Hello World! ABCDE 中文测试”

  11. 文本处理 (文本, &文本处理程序)
  12. 调试输出 (文本)


  13. .子程序 文本处理, , 公开, 通过自定义子程序处理一段文本型字符串
  14. .参数 欲处理的文本, 文本型, 参考
  15. .参数 文本处理子程序, 子程序指针, , 参数1:位置(1为首地址,整数型) 参数2:Ascii码(字节型) 返回值:字节型(将写入文本) 返回0将终止转换

  16. 置入代码 ({ 96, 139, 93, 8, 139, 27, 139, 117, 12, 184, 0, 0, 0, 0, 185, 1, 0, 0, 0, 138, 3, 10, 192, 117, 5, 97, 201, 194, 8, 0, 81, 80, 81, 255, 214, 89, 136, 3, 10, 192, 117, 5, 97, 201, 194, 8, 0, 67, 65, 235, 224 })


  17. .子程序 文本处理程序, 字节型, 公开, 到小写
  18. .参数 地址, 整数型
  19. .参数 值, 字节型

  20. .如果真 (值 ≥ 65 且 值 ≤ 90)
  21.     返回 (值 + 32)
  22. .如果真结束
  23. 返回 (值)


复制代码

相关帖子

回复

使用道具 举报

腾讯云服务器安全可靠高性能,多种配置供您选择
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则