免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 59|回复: 1
收起左侧

易语言汇编置入代码实现长整数型数组变量的按位取反(not)、非运算极速操作 (无返回值)

[复制链接]
发表于 2019-7-17 08:03:16 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 QAQ 于 2019-7-9 21:05 编辑

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 长整数型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = { 1234567890, 9876543210, 12345, 54321, 1.234512345123e+014 }
  11. 调试输出 (A)
  12. 长整数型数组_取反 (A)
  13. 调试输出 (A)
  14. 长整数型数组_取反 (A)
  15. 调试输出 (A)


  16. .子程序 长整数型数组_取反, , 公开
  17. .参数 长整数型数组, 长整数型, 参考 数组, 必须为变量

  18. 置入代码 ({ 96, 139, 69, 8, 139, 0, 139, 88, 4, 131, 192, 8, 190, 0, 0, 0, 0, 235, 19, 139, 12, 240, 139, 84, 240, 4, 247, 209, 247, 210, 137, 12, 240, 137, 84, 240, 4, 70, 59, 243, 114, 233, 97, 201, 194, 4, 0 })
  19. ' pushad
  20. ' mov eax,[ebp+8]
  21. ' mov eax,[eax]
  22. ' mov ebx,[eax+4]
  23. ' add eax,8
  24. ' mov esi,0
  25. ' .while esi<ebx
  26. ' mov ecx,[eax+esi*8]
  27. ' mov edx,[eax+esi*8+4]
  28. ' not ecx
  29. ' not edx
  30. ' mov [eax+esi*8],ecx
  31. ' mov [eax+esi*8+4],edx
  32. ' inc esi
  33. ' .endw
  34. ' popad
  35. ' leave
  36. ' retn 4

复制代码

相关帖子

回复

使用道具 举报

腾讯云为数百万企业和开发者提供安全、稳定的云服务器、云数据库、CDN等云服务
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则