免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 82|回复: 2
收起左侧

易语言置入代码实现检测字节集数组中是否有不等于指定长度的字节集成员 (返回逻辑型)

[复制链接]
发表于 2019-7-17 12:01:16 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 字节集数组, 字节集, , "4"

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 字节集数组 [1] = { 192, 168, 1, 1 }
  10. 字节集数组 [2] = { 0, 0, 0, 0 }
  11. 字节集数组 [3] = { 123, 123, 123, 123 }
  12. 字节集数组 [4] = { 127, 0, 0, 1 }

  13. 输出调试文本 (字节集数组_是否有不等于指定长度的成员 (字节集数组, 4))
  14. 字节集数组 [1] = { 192, 168, 1, 1, 1 }
  15. 字节集数组 [2] = { 0, 0, 0, 0 }
  16. 字节集数组 [3] = { 123, 123, 123, 123 }
  17. 字节集数组 [4] = { 127, 0, 0, 1 }

  18. 输出调试文本 (字节集数组_是否有不等于指定长度的成员 (字节集数组, 4))
  19. 字节集数组 [1] = { 192, 168, 1, 1 }
  20. 字节集数组 [2] = { 0, 0, 0 }
  21. 字节集数组 [3] = { 123, 123, 123, 123 }
  22. 字节集数组 [4] = { 127, 0, 0, 1 }

  23. 输出调试文本 (字节集数组_是否有不等于指定长度的成员 (字节集数组, 4))


  24. .子程序 字节集数组_是否有不等于指定长度的成员, 逻辑型, 公开
  25. .参数 字节集数组, 字节集, 数组
  26. .参数 检测长度, 整数型, , 字节集数组中所有成员的长度等于该值返回假,否则返回真,必须大于等于0

  27. 置入代码 ({ 83, 81, 82, 86, 139, 69, 8, 139, 117, 12, 139, 24, 139, 67, 4, 131, 195, 8, 51, 201, 235, 18, 139, 20, 139, 139, 82, 4, 59, 214, 116, 7, 184, 1, 0, 0, 0, 235, 7, 65, 59, 200, 114, 234, 51, 192, 94, 90, 89, 91, 201, 194, 8, 0 })
  28. ' push ebx
  29. ' push ecx
  30. ' push edx
  31. ' push esi
  32. ' mov eax,[ebp+8]
  33. ' mov esi,[ebp+12]
  34. ' mov ebx,[eax]
  35. ' mov eax,[ebx+4]
  36. ' add ebx,8
  37. ' xor ecx,ecx
  38. ' .while ecx<eax
  39. ' mov edx,[ebx+ecx*4]
  40. ' mov edx,[edx+4]
  41. ' .if edx !=esi
  42. ' mov eax,1
  43. ' jmp ASM_END
  44. ' .endif
  45. ' inc ecx
  46. ' .endw
  47. ' xor eax,eax
  48. ' ASM_END:
  49. ' pop esi
  50. ' pop edx
  51. ' pop ecx
  52. ' pop ebx
  53. ' leave
  54. ' retn 8
  55. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
发表于 2019-7-18 06:31:45 | 显示全部楼层
Cute 发表于 2019-7-17 21:04
看了半天才明白

我也一样
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则