免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 60|回复: 0
收起左侧

易语言置入代码实现16位短整数型数组变量所有成员按位取反(not),非运算操作(无返回值)

[复制链接]
发表于 2019-7-19 16:31:09 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 短整数型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = { 1, 2, 3, 4, 5, 12345, -23456, 1234, -2345, 111 }
  11. 调试输出 (A)
  12. 短整数型数组_取反 (A)
  13. 调试输出 (A)

  14. .子程序 短整数型数组_取反, , 公开
  15. .参数 短整数型数组, 短整数型, 参考 数组, 必须为变量

  16. 置入代码 ({ 96, 139, 69, 8, 139, 0, 139, 88, 4, 131, 192, 8, 51, 246, 235, 12, 102, 139, 12, 112, 102, 247, 209, 102, 137, 12, 112, 70, 59, 243, 114, 240, 97, 201, 194, 4, 0 })
  17. ' pusha
  18. ' mov eax,[ebp+8]
  19. ' mov eax,[eax]
  20. ' mov ebx,[eax+4]
  21. ' add eax,8
  22. ' xor esi,esi
  23. ' .while esi < ebx
  24. ' mov cx,[eax+esi*2]
  25. ' not cx
  26. ' mov [eax+esi*2],cx
  27. ' inc esi
  28. ' .endw
  29. ' popa
  30. ' leave
  31. ' retn 4

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则