免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 77|回复: 0
收起左侧

易语言MASM汇编置入代码实现小数型(3.14159)与整数型(1078530011,0x40490FDB)强制互转

[复制链接]
发表于 2019-7-24 18:15:15 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 整数, 整数型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 整数 = 小数型到整数型 (#pi)
  10. 输出调试文本 (整数, 整数型到小数型 (整数))

  11. .子程序 小数型到整数型, 整数型, , 本函数是将小数的所有数据转换成整数型,不是将小数的整数部分转换成整数型,错误使用将会造成数据异常。
  12. .参数 值, 小数型, , 提供 3.14159 将返回 1078530011,转换前请注意字节序(大小端)

  13. 置入代码 ({ 139, 69, 8, 201, 194, 4, 0 })
  14. ' mov eax,[ebp+8]
  15. ' leave
  16. ' retn 4
  17. 返回 (0)

  18. .子程序 整数型到小数型, 小数型, , 与 小数型到整数型() 过程相反,错误使用将会造成数据异常。
  19. .参数 值, 整数型, , 提供 1078530011 将返回 3.14159,转换前请注意字节序(大小端)

  20. 置入代码 ({ 139, 69, 8, 201, 194, 4, 0 })
  21. ' mov eax,[ebp+8]
  22. ' leave
  23. ' retn 4
  24. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则