免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 100|回复: 1
收起左侧

易语言MASM置入代码实现 交换指针数据() 地址内存数据互相转移指定长度 (返回逻辑型)

[复制链接]
发表于 2019-8-6 07:04:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 字节集
  9. .局部变量 B, 字节集
  10. .局部变量 指针A, 整数型
  11. .局部变量 指针B, 整数型

  12. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  13. A = { 1, 2, 3, 4, 5 }
  14. B = { 100, 200, 123, 234, 101 }

  15. 指针A = 取变量数据地址 (A)
  16. 指针B = 取变量数据地址 (B)
  17. 调试输出 (A, B)
  18. 检查 (交换指针数据 (指针A, 指针B, 5))
  19. 调试输出 (A, B)


  20. .子程序 交换指针数据, 逻辑型, 公开, 指针A与指针B的内存数据互相交换转移,成功返回真失败返回假
  21. .参数 指针A, 整数型, , 指针必须真实有效
  22. .参数 指针B, 整数型, , 不得与指针A相同
  23. .参数 交换长度, 整数型, , 必须大于等于1

  24. 置入代码 ({ 83, 81, 82, 86, 87, 139, 69, 8, 139, 93, 12, 139, 117, 16, 139, 254, 129, 231, 0, 0, 0, 128, 59, 195, 116, 8, 11, 255, 117, 4, 11, 246, 117, 4, 51, 192, 235, 26, 51, 201, 235, 13, 138, 20, 1, 138, 52, 25, 136, 20, 25, 136, 52, 1, 65, 59, 206, 114, 239, 184, 1, 0, 0, 0, 95, 94, 90, 89, 91, 201, 194, 12, 0 })
  25. ' push ebx
  26. ' push ecx
  27. ' push edx
  28. ' push esi
  29. ' push edi
  30. ' mov eax,[ebp+8]
  31. ' mov ebx,[ebp+12]
  32. ' mov esi,[ebp+16]
  33. ' mov edi,esi
  34. ' and edi,80000000H
  35. ' .if eax == ebx || edi != 0 || esi == 0
  36. ' xor eax,eax
  37. ' jmp ASM_END
  38. ' .endif
  39. ' xor ecx,ecx
  40. ' .while ecx < esi
  41. ' mov dl,[eax+ecx]
  42. ' mov dh,[ebx+ecx]
  43. ' mov [ebx+ecx],dl
  44. ' mov [eax+ecx],dh
  45. ' inc ecx
  46. ' .endw
  47. ' mov eax,1
  48. ' ASM_END:
  49. ' pop edi
  50. ' pop esi
  51. ' pop edx
  52. ' pop ecx
  53. ' pop ebx
  54. ' leave
  55. ' retn 12

  56. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

腾讯云为数百万企业和开发者提供安全、稳定的云服务器、云数据库、CDN等云服务
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则