免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 414|回复: 3
收起左侧

易语言 首字母大小写转换的实现方法 相当于php的 ucwords() 与 lcfirst() 函数。

[复制链接]
发表于 2017-9-8 09:17:18 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
  1. .版本 2
  2. .支持库 spec

  3. .程序集 窗口程序集_启动窗口, , , 易语言 首字母大小写转换的实现方法 相当于php的 ucwords() 与 lcfirst() 函数

  4. .子程序 __启动窗口_创建完毕


  5. 调试输出 (首字母到大写 (“hello world!”))
  6. 调试输出 (首字母到小写 (“HELLO WORLD!”))



  7. .子程序 首字母到大写, 文本型, 公开
  8. .参数 欲变换的文本, 文本型
  9. .局部变量 分割后, 文本型, , "0"
  10. .局部变量 计数, 整数型
  11. .局部变量 首字母, 文本型
  12. .局部变量 返回值, 文本型


  13. 分割后 = 分割文本 (欲变换的文本, “ ”, )
  14. .计次循环首 (取数组成员数 (分割后), 计数)
  15.     返回值 = 返回值 + 到大写 (取文本左边 (分割后 [计数], 1)) + 取文本右边 (分割后 [计数], 取文本长度 (分割后 [计数]) - 1) + “ ”
  16. .计次循环尾 ()
  17. 返回 (返回值)


  18. .子程序 首字母到小写, 文本型, 公开
  19. .参数 欲变换的文本, 文本型
  20. .局部变量 分割后, 文本型, , "0"
  21. .局部变量 计数, 整数型
  22. .局部变量 首字母, 文本型
  23. .局部变量 返回值, 文本型

  24. 分割后 = 分割文本 (欲变换的文本, “ ”, )
  25. .计次循环首 (取数组成员数 (分割后), 计数)
  26.     返回值 = 返回值 + 到小写 (取文本左边 (分割后 [计数], 1)) + 取文本右边 (分割后 [计数], 取文本长度 (分割后 [计数]) - 1) + “ ”
  27. .计次循环尾 ()
  28. 返回 (返回值)

复制代码


相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2017-9-8 17:33:34 | 显示全部楼层
666,就这玩意度娘1个也搜不到。
回复 支持 反对

使用道具 举报

发表于 2017-9-9 13:27:18 | 显示全部楼层
以后某数字套装一搜易语言+指定php字符串处理函数,保不准全是这里的。
回复 支持 反对

使用道具 举报

发表于 2017-9-22 16:44:28 来自手机 | 显示全部楼层
吃瓜群众 发表于 2017-9-9 13:27
以后某数字套装一搜易语言+指定php字符串处理函数,保不准全是这里的。

一切皆有可能。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则