免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 318|回复: 3
收起左侧

易语言实现控制台文本自动转义 批处理echo转义 可显示、处理任意特殊符号

[复制链接]
发表于 2018-5-2 22:00:21 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 优先级 于 2018-5-2 22:23 编辑

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
  5. .局部变量 字符, 文本型

  6. 置随机数种子 ()
  7. 字符 = 随机字符 ()
  8. 标准输出 (, 字符 + #换行符)
  9. 调试输出 (控制台文本转义 (字符))
  10. 运行 (“cmd /c echo ” + 控制台文本转义 (字符), 真, )
  11. 运行 (“cmd /c pause”, 真, )

  12. 返回 (0)  ' 可以根据您的需要返回任意数值

  13. .子程序 随机字符, 文本型
  14. .局部变量 允许出现的字符, 文本型
  15. .局部变量 文本, 文本型

  16. 允许出现的字符 = “0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz^!#$%&'()*+,-./:;<=>?@[\]_`{|}~” + #引号
  17. .计次循环首 (64, )
  18.     文本 = 文本 + 取文本中间 (允许出现的字符, 取随机数 (1, 取文本长度 (允许出现的字符)), 1)
  19. .计次循环尾 ()
  20. 返回 (文本)

  21. .子程序 控制台文本转义, 文本型, 公开
  22. .参数 文本, 文本型
  23. .局部变量 计数, 整数型
  24. .局部变量 单字符, 文本型
  25. .局部变量 文本2, 文本型

  26. 文本2 = 文本
  27. .计次循环首 (7, 计数)
  28.     单字符 = 取文本中间 (“^%&*<>|”, 计数, 1)
  29.     文本2 = 子文本替换 (文本2, 单字符, “^” + 单字符, , , 真)
  30. .计次循环尾 ()
  31. 返回 (文本2)

复制代码

相关帖子

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
发表于 2018-7-24 07:14:54 | 显示全部楼层
地板也是我的
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-18 06:01, 3.227.233.55 , Processed in 0.552204 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表