免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 597|回复: 3
收起左侧

易语言 取命令行() 调试参数行中引号的正确使用方法

[复制链接]
回帖奖励 40 枚从币 回复本帖可获得 8 枚从币奖励! 每人限 1 次
发表于 2018-5-9 10:54:58 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
如果编译后的exe程序需要关联其他格式扩展名的文件,或者有一个、多个文件拖放到该exe中,就需要通过 取命令行 () 语句进行读取。
也可以添加到开机自启动项或快捷方式中,启动时带上指定的参数,即可防止误直接双击而启动exe,也可以实现1个exe,多个快捷方式而实现多个功能。
新建一个 Windows 窗口程序,粘贴以下代码:

  1. .版本 2
  2. .支持库 spec

  3. .程序集 窗口程序集_启动窗口

  4. .子程序 __启动窗口_创建完毕
  5. .局部变量 命令行, 文本型, , "0"
  6. .局部变量 计数, 整数型

  7. 取命令行 (命令行)
  8. .如果真 (假)
  9.     .计次循环首 (取数组成员数 (命令行), 计数)
  10.         .如果真 (命令行 [计数] = 字符 (0))
  11.             命令行 [计数] = #引号
  12.         .如果真结束

  13.     .计次循环尾 ()
  14. .如果真结束
  15. 调试输出 (命令行)
  16. 结束 ()
复制代码



点击程序->配置 弹出程序配置对话框:

在调试参数行 输入以下文本:
  1. A B C
复制代码

返回以下结果:
  1. * 数组:3{“A”,“B”,“C”}
复制代码

加上半角引号后,返回以下结果:
  1. * 数组:1{“A B C”}
复制代码

参数:
  1. A "B C"
复制代码

返回:
  1. 2{“A”,“B C”}
复制代码


参数:
  1. A "B C" ""
复制代码

返回:
  1. * 数组:3{“A”,“B C”,“”}
复制代码

易语言中命令行默认是不支持引号传递的,可将 如果真(假) 部分修改为真,即可将数组中的空文本替换为引号。
返回:
  1. * 数组:3{“A”,“B C”,“"”}
复制代码


相关帖子

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
发表于 2018-5-9 11:33:45 | 显示全部楼层

回帖奖励 +8 枚从币

原来都是酱紫的
回复 支持 反对

使用道具 举报

发表于 2018-5-9 16:21:27 | 显示全部楼层

回帖奖励 +8 枚从币

看来引号真不能乱用
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则