免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 258|回复: 2
收起左侧

易语言创建目录增强版解决系统自带创建目录无法创建多级目录的bug,相当于cmd的md命令

[复制链接]
发表于 2018-8-27 12:07:15 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  8. 输出调试文本 (创建目录增强 (“D:\123\456\789\”))



  9. .子程序 创建目录增强, 逻辑型, 公开,  本方法是解决核心库的 创建目录 命令的bug 无法创建多个目录的问题,若新版核心库修复了此bug,此方法则可以忽略。
  10. .参数 欲创建的目录名称, 文本型
  11. .局部变量 目录名, 文本型, , "0"
  12. .局部变量 创建的目录名, 文本型
  13. .局部变量 目录层数, 整数型
  14. .局部变量 外循环, 整数型
  15. .局部变量 内循环, 整数型
  16. .局部变量 创建成功, 逻辑型

  17. 目录名 = 分割文本 (子文本替换 (欲创建的目录名称, “/”, “\”, , , 真), “\”, )
  18. 目录层数 = 取数组成员数 (目录名)
  19. .计次循环首 (目录层数, 外循环)
  20.     创建的目录名 = “”
  21.     .计次循环首 (外循环, 内循环)
  22.         创建的目录名 = 创建的目录名 + 目录名 [内循环] + “\”
  23.     .计次循环尾 ()
  24.     .如果真 (取文本右边 (创建的目录名, 2) ≠ “:\”)
  25.         创建成功 = 创建目录 (创建的目录名)
  26.     .如果真结束

  27. .计次循环尾 ()
  28. 返回 (创建成功)
复制代码


相关帖子

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
发表于 2018-8-27 18:05:13 | 显示全部楼层
核心库就连这种低级bug都有...
回复 支持 反对

使用道具 举报

发表于 2018-8-28 13:54:41 | 显示全部楼层
哒哒哒 发表于 2018-8-27 18:05
核心库就连这种低级bug都有...

这个命令目前只能一次创建一个目录。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 15:19, 34.236.190.216 , Processed in 0.219726 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表