设为首页收藏本站帮助中心
查看: 1437|回复: 5
收起左侧

易语言字节集数据2~256进制转换器模块源码

[复制链接]
发表于 2018-9-1 20:09:12 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (字节集进制转换 ({ 1, 0, 1, 0, 1, 0, 1, 2 }, 2, 255))

  10. .子程序 字节集进制转换, 字节集, 公开, 对字节集数据进行2~256进制转换
  11. .参数 欲操作的数据, 字节集, , 若对数字字母文本进行进制转换需先转换Ascii码
  12. .参数 原进制, 字节型, , 字节集中出现的值不能超过此值否则会出错
  13. .参数 目标进制, 字节型, , 2进制为1、3进制为2、256进制为255、以此类推
  14. .局部变量 计数, 整数型
  15. .局部变量 长度, 整数型
  16. .局部变量 运算值, 整数型
  17. .局部变量 返回值, 字节集
  18. .局部变量 数组, 字节型, , "0"


  19. 长度 = 取字节集长度 (欲操作的数据)
  20. .判断开始 (原进制 = 0 或 目标进制 = 0 或 长度 = 0)
  21.     返回 ({  })
  22. .判断 (原进制 = 目标进制)
  23.     返回 (欲操作的数据)
  24. .默认

  25. .判断结束
  26. 重定义数组 (数组, 假, 长度)
  27. .计次循环首 (长度, 计数)
  28.     数组 [计数] = 欲操作的数据 [计数]
  29. .计次循环尾 ()
  30. .判断循环首 (长度 ≥ 1)
  31.     运算值 = 0
  32.     .计次循环首 (长度, 计数)
  33.         运算值 = 运算值 × (原进制 + 1) + 数组 [计数]
  34.         数组 [计数] = 运算值 ÷ (目标进制 + 1)
  35.         运算值 = 运算值 % (目标进制 + 1)
  36.     .计次循环尾 ()
  37.     返回值 = 到字节集 (到字节 (运算值)) + 返回值
  38.     运算值 = 1
  39.     .判断循环首 (运算值 ≤ 长度 且 数组 [运算值] = 0)
  40.         运算值 = 运算值 + 1
  41.     .判断循环尾 ()
  42.     删除成员 (数组, 1, 运算值 - 1)
  43.     长度 = 取数组成员数 (数组)
  44. .判断循环尾 ()
  45. 返回 (返回值)
复制代码


相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

发表于 2018-9-1 20:39:28 | 显示全部楼层
据说这玩意能压缩数据
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2018-9-1 22:06:58 | 显示全部楼层
啧啧啧 发表于 2018-9-1 20:39
据说这玩意能压缩数据

这本来就是设计压缩算法用的到的。
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2018-9-2 10:07:19 | 显示全部楼层
原来还有这玩意,谢谢分享
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2018-9-2 23:43:23 | 显示全部楼层
Cute 发表于 2018-9-1 22:06
这本来就是设计压缩算法用的到的。

哦,原来如此。
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则