免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 166|回复: 1
收起左侧

易语言实现各种基本数据类型数组的成员倒序排列

[复制链接]
发表于 2018-9-12 19:01:59 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x


  1. .版本 2

  2. .程序集 数组倒序, , , 将数组中的成员倒序排列

  3. .子程序 数组倒序_字节型, , 公开
  4. .参数 欲倒序的数组, 字节型, 参考 数组
  5. .局部变量 数组2, 字节型, , "0"
  6. .局部变量 成员数, 整数型
  7. .局部变量 计数, 整数型

  8. 成员数 = 取数组成员数 (欲倒序的数组)
  9. 重定义数组 (数组2, 假, 成员数)
  10. .计次循环首 (成员数, 计数)
  11.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  12. .计次循环尾 ()
  13. 欲倒序的数组 = 数组2


  14. .子程序 数组倒序_整数型, , 公开
  15. .参数 欲倒序的数组, 整数型, 参考 数组
  16. .局部变量 数组2, 整数型, , "0"
  17. .局部变量 成员数, 整数型
  18. .局部变量 计数, 整数型

  19. 成员数 = 取数组成员数 (欲倒序的数组)
  20. 重定义数组 (数组2, 假, 成员数)
  21. .计次循环首 (成员数, 计数)
  22.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  23. .计次循环尾 ()
  24. 欲倒序的数组 = 数组2


  25. .子程序 数组倒序_小数型, , 公开
  26. .参数 欲倒序的数组, 小数型, 参考 数组
  27. .局部变量 数组2, 小数型, , "0"
  28. .局部变量 成员数, 整数型
  29. .局部变量 计数, 整数型

  30. 成员数 = 取数组成员数 (欲倒序的数组)
  31. 重定义数组 (数组2, 假, 成员数)
  32. .计次循环首 (成员数, 计数)
  33.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  34. .计次循环尾 ()
  35. 欲倒序的数组 = 数组2


  36. .子程序 数组倒序_逻辑型, , 公开
  37. .参数 欲倒序的数组, 逻辑型, 参考 数组
  38. .局部变量 数组2, 逻辑型, , "0"
  39. .局部变量 成员数, 整数型
  40. .局部变量 计数, 整数型

  41. 成员数 = 取数组成员数 (欲倒序的数组)
  42. 重定义数组 (数组2, 假, 成员数)
  43. .计次循环首 (成员数, 计数)
  44.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  45. .计次循环尾 ()
  46. 欲倒序的数组 = 数组2


  47. .子程序 数组倒序_文本型, , 公开
  48. .参数 欲倒序的数组, 文本型, 参考 数组
  49. .局部变量 数组2, 文本型, , "0"
  50. .局部变量 成员数, 整数型
  51. .局部变量 计数, 整数型

  52. 成员数 = 取数组成员数 (欲倒序的数组)
  53. 重定义数组 (数组2, 假, 成员数)
  54. .计次循环首 (成员数, 计数)
  55.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  56. .计次循环尾 ()
  57. 欲倒序的数组 = 数组2


  58. .子程序 数组倒序_字节集, , 公开
  59. .参数 欲倒序的数组, 字节集, 参考 数组
  60. .局部变量 数组2, 字节集, , "0"
  61. .局部变量 成员数, 整数型
  62. .局部变量 计数, 整数型

  63. 成员数 = 取数组成员数 (欲倒序的数组)
  64. 重定义数组 (数组2, 假, 成员数)
  65. .计次循环首 (成员数, 计数)
  66.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  67. .计次循环尾 ()
  68. 欲倒序的数组 = 数组2


  69. .子程序 数组倒序_短整数型, , 公开
  70. .参数 欲倒序的数组, 短整数型, 参考 数组
  71. .局部变量 数组2, 短整数型, , "0"
  72. .局部变量 成员数, 整数型
  73. .局部变量 计数, 整数型

  74. 成员数 = 取数组成员数 (欲倒序的数组)
  75. 重定义数组 (数组2, 假, 成员数)
  76. .计次循环首 (成员数, 计数)
  77.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  78. .计次循环尾 ()
  79. 欲倒序的数组 = 数组2


  80. .子程序 数组倒序_长整数型, , 公开
  81. .参数 欲倒序的数组, 长整数型, 参考 数组
  82. .局部变量 数组2, 长整数型, , "0"
  83. .局部变量 成员数, 整数型
  84. .局部变量 计数, 整数型

  85. 成员数 = 取数组成员数 (欲倒序的数组)
  86. 重定义数组 (数组2, 假, 成员数)
  87. .计次循环首 (成员数, 计数)
  88.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  89. .计次循环尾 ()
  90. 欲倒序的数组 = 数组2


  91. .子程序 数组倒序_日期时间型, , 公开
  92. .参数 欲倒序的数组, 日期时间型, 参考 数组
  93. .局部变量 数组2, 日期时间型, , "0"
  94. .局部变量 成员数, 整数型
  95. .局部变量 计数, 整数型

  96. 成员数 = 取数组成员数 (欲倒序的数组)
  97. 重定义数组 (数组2, 假, 成员数)
  98. .计次循环首 (成员数, 计数)
  99.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  100. .计次循环尾 ()
  101. 欲倒序的数组 = 数组2


  102. .子程序 数组倒序_子程序指针, , 公开
  103. .参数 欲倒序的数组, 子程序指针, 参考 数组
  104. .局部变量 数组2, 子程序指针, , "0"
  105. .局部变量 成员数, 整数型
  106. .局部变量 计数, 整数型

  107. 成员数 = 取数组成员数 (欲倒序的数组)
  108. 重定义数组 (数组2, 假, 成员数)
  109. .计次循环首 (成员数, 计数)
  110.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  111. .计次循环尾 ()
  112. 欲倒序的数组 = 数组2


  113. .子程序 数组倒序_双精度小数型, , 公开
  114. .参数 欲倒序的数组, 双精度小数型, 参考 数组
  115. .局部变量 数组2, 双精度小数型, , "0"
  116. .局部变量 成员数, 整数型
  117. .局部变量 计数, 整数型

  118. 成员数 = 取数组成员数 (欲倒序的数组)
  119. 重定义数组 (数组2, 假, 成员数)
  120. .计次循环首 (成员数, 计数)
  121.     数组2 [计数] = 欲倒序的数组 [成员数 - 计数 + 1]
  122. .计次循环尾 ()
  123. 欲倒序的数组 = 数组2
复制代码


相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2018-9-12 22:01:49 | 显示全部楼层
这么多水贴
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则