免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 178|回复: 4
收起左侧

易语言实现基本数据类型数组快速去除重复的方法 采用吃尾算法实现

[复制链接]
发表于 2018-9-12 19:24:20 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 Cute 于 2018-9-12 21:45 编辑

  1. .版本 2

  2. .程序集 数组去重, , , 将数组中重复的成员批量删除

  3. .子程序 数组去重_字节型, , 公开
  4. .参数 欲去重的数组, 字节型, 参考 数组
  5. .局部变量 外循环, 整数型
  6. .局部变量 内循环, 整数型

  7. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  8.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  9.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  10.             删除成员 (欲去重的数组, 内循环, )

  11.         .如果真结束

  12.     .变量循环尾 ()
  13. .计次循环尾 ()

  14. .子程序 数组去重_整数型, , 公开
  15. .参数 欲去重的数组, 整数型, 参考 数组
  16. .局部变量 外循环, 整数型
  17. .局部变量 内循环, 整数型

  18. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  19.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  20.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  21.             删除成员 (欲去重的数组, 内循环, )

  22.         .如果真结束

  23.     .变量循环尾 ()
  24. .计次循环尾 ()

  25. .子程序 数组去重_小数型, , 公开
  26. .参数 欲去重的数组, 小数型, 参考 数组
  27. .局部变量 外循环, 整数型
  28. .局部变量 内循环, 整数型

  29. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  30.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  31.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  32.             删除成员 (欲去重的数组, 内循环, )

  33.         .如果真结束

  34.     .变量循环尾 ()
  35. .计次循环尾 ()


  36. .子程序 数组去重_逻辑型, , 公开
  37. .参数 欲去重的数组, 逻辑型, 参考 数组
  38. .局部变量 计数, 整数型
  39. .局部变量 数组2, 逻辑型, , "0"
  40. .局部变量 存在真, 逻辑型
  41. .局部变量 存在假, 逻辑型

  42. .计次循环首 (取数组成员数 (欲去重的数组), 计数)
  43.     .如果 (欲去重的数组 [计数])
  44.         .如果真 (存在真 = 假)
  45.             加入成员 (数组2, 真)
  46.             存在真 = 真
  47.         .如果真结束

  48.     .否则
  49.         .如果真 (存在假 = 假)
  50.             加入成员 (数组2, 假)
  51.             存在假 = 真
  52.         .如果真结束

  53.     .如果结束
  54.     .如果真 (存在真 且 存在假)
  55.         跳出循环 ()
  56.     .如果真结束

  57. .计次循环尾 ()
  58. 欲去重的数组 = 数组2

  59. .子程序 数组去重_文本型, , 公开
  60. .参数 欲去重的数组, 文本型, 参考 数组
  61. .局部变量 外循环, 整数型
  62. .局部变量 内循环, 整数型

  63. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  64.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  65.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  66.             删除成员 (欲去重的数组, 内循环, )

  67.         .如果真结束

  68.     .变量循环尾 ()
  69. .计次循环尾 ()


  70. .子程序 数组去重_字节集, , 公开
  71. .参数 欲去重的数组, 字节集, 参考 数组
  72. .局部变量 外循环, 整数型
  73. .局部变量 内循环, 整数型

  74. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  75.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  76.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  77.             删除成员 (欲去重的数组, 内循环, )

  78.         .如果真结束

  79.     .变量循环尾 ()
  80. .计次循环尾 ()


  81. .子程序 数组去重_短整数型, , 公开
  82. .参数 欲去重的数组, 短整数型, 参考 数组
  83. .局部变量 外循环, 整数型
  84. .局部变量 内循环, 整数型

  85. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  86.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  87.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  88.             删除成员 (欲去重的数组, 内循环, )

  89.         .如果真结束

  90.     .变量循环尾 ()
  91. .计次循环尾 ()


  92. .子程序 数组去重_长整数型, , 公开
  93. .参数 欲去重的数组, 长整数型, 参考 数组
  94. .局部变量 外循环, 整数型
  95. .局部变量 内循环, 整数型

  96. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  97.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  98.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  99.             删除成员 (欲去重的数组, 内循环, )

  100.         .如果真结束

  101.     .变量循环尾 ()
  102. .计次循环尾 ()


  103. .子程序 数组去重_日期时间型, , 公开
  104. .参数 欲去重的数组, 日期时间型, 参考 数组
  105. .局部变量 外循环, 整数型
  106. .局部变量 内循环, 整数型

  107. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  108.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  109.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  110.             删除成员 (欲去重的数组, 内循环, )

  111.         .如果真结束

  112.     .变量循环尾 ()
  113. .计次循环尾 ()


  114. .子程序 数组去重_子程序指针, , 公开
  115. .参数 欲去重的数组, 子程序指针, 参考 数组
  116. .局部变量 外循环, 整数型
  117. .局部变量 内循环, 整数型

  118. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  119.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  120.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  121.             删除成员 (欲去重的数组, 内循环, )

  122.         .如果真结束

  123.     .变量循环尾 ()
  124. .计次循环尾 ()


  125. .子程序 数组去重_双精度小数型, , 公开
  126. .参数 欲去重的数组, 双精度小数型, 参考 数组
  127. .局部变量 外循环, 整数型
  128. .局部变量 内循环, 整数型

  129. .计次循环首 (取数组成员数 (欲去重的数组), 外循环)
  130.     .变量循环首 (取数组成员数 (欲去重的数组), 外循环 + 1, -1, 内循环)
  131.         .如果真 (欲去重的数组 [外循环] = 欲去重的数组 [内循环])
  132.             删除成员 (欲去重的数组, 内循环, )

  133.         .如果真结束

  134.     .变量循环尾 ()
  135. .计次循环尾 ()

复制代码

相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2018-9-12 21:32:14 | 显示全部楼层
本帖最后由 Cute 于 2018-9-12 21:46 编辑

逻辑型的去完了结果真的很,我帮你改改....
回复 支持 反对

使用道具 举报

发表于 2018-9-12 22:02:08 | 显示全部楼层
老司机老司机
回复 支持 反对

使用道具 举报

发表于 2018-9-13 09:28:03 | 显示全部楼层
看看咋吃的
回复 支持 反对

使用道具 举报

发表于 2018-9-13 13:11:12 | 显示全部楼层
Cute 发表于 2018-9-12 21:32
逻辑型的去完了结果真的很,我帮你改改....

改的真6....
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-18 06:01, 3.227.233.55 , Processed in 0.375401 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表