免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 168|回复: 2
收起左侧

无需置入代码 通过内存操作以最快的速度读写文本字符串中某个位置的值

[复制链接]
发表于 2018-9-14 19:14:17 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 文本1, 文本型
  9. .局部变量 计数, 整数型
  10. .局部变量 文本2, 文本型
  11. .局部变量 时间, 整数型

  12. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  13. 文本1 = “ABC123def456”
  14. .计次循环首 (取文本长度 (文本1), 计数)
  15.     调试输出 (字符 (取代码 (文本1, 计数)))
  16. .计次循环尾 ()
  17. 调试输出 (“开始创建空白文本...”)
  18. 文本2 = 取空白文本 (20000)
  19. 调试输出 (“开始处理”)
  20. 时间 = 取启动时间 ()

  21. .计次循环首 (取文本长度 (文本2), 计数)
  22.     置代码 (文本2, 计数, 48)
  23. .计次循环尾 ()
  24. 调试输出 (“写时间”, 取启动时间 () - 时间)

  25. 时间 = 取启动时间 ()

  26. .计次循环首 (取文本长度 (文本2), 计数)
  27.     取代码 (文本2, 计数)
  28. .计次循环尾 ()
  29. 调试输出 (“读时间”, 取启动时间 () - 时间)


  30. .子程序 置代码, , 公开, 修改文本中指定位置处字符的代码,与核心库自带的的 取代码() 配套使用。
  31. .参数 欲置字符代码的文本, 文本型, 参考, 必须是变量 操作前建议使用 取空白文本 () 创建,不支持改变文本长度。
  32. .参数 欲置其代码的字符位置, 整数型, , 1为首位置,2为第二位置,越界或小于1则会造成内存垃圾或程序崩溃。
  33. .参数 欲置其代码的字符值, 字节型

  34. 写到内存 (欲置其代码的字符值, 取变量数据地址 (欲置字符代码的文本) - 1 + 欲置其代码的字符位置, 1)

复制代码


相关帖子

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:28, 107.23.37.199 , Processed in 0.093752 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表