免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 236|回复: 1
收起左侧

易语言实现两个字节集的近似等于比较功能 采用置入代码实现

[复制链接]
发表于 2018-9-21 21:14:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 字节集1, 字节集
  9. .局部变量 字节集2, 字节集

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. 字节集1 = { 1, 2, 3, 4, 5, 6 }
  12. 字节集2 = { 1, 2, 3 }

  13. 调试输出 (字节集_近似等于 (字节集1, 字节集2), 到文本 (字节集1) ≈ 到文本 (字节集2))


  14. .子程序 字节集_近似等于, 逻辑型, 公开, 当比较字节集在被比较字节集的首部被包容时返回真,否则返回假
  15. .参数 被比较字节集, 字节集
  16. .参数 比较字节集, 字节集

  17. 置入代码 ({ 139, 69, 8, 139, 16, 139, 66, 4, 139, 93, 12, 139, 11, 139, 89, 4, 11, 192, 117, 13, 11, 219, 117, 9, 184, 1, 0, 0, 0, 235, 102, 235, 45, 11, 192, 117, 13, 11, 219, 116, 9, 184, 0, 0, 0, 0, 235, 85, 235, 28, 11, 192, 116, 13, 11, 219, 117, 9, 184, 1, 0, 0, 0, 235, 68, 235, 11, 59, 216, 118, 7, 184, 0, 0, 0, 0, 235, 55, 184, 0, 0, 0, 0, 131, 194, 8, 131, 193, 8, 235, 21, 83, 138, 28, 16, 138, 60, 8, 56, 251, 116, 8, 184, 0, 0, 0, 0, 91, 235, 23, 91, 64, 59, 195, 114, 231, 131, 248, 0, 118, 7, 184, 1, 0, 0, 0, 235, 5, 184, 0, 0, 0, 0, 201, 194, 8, 0 })
  18. ' mov eax,[ebp+8]
  19. ' mov edx,[eax]
  20. ' mov eax,[edx+4]
  21. ' mov ebx,[ebp+12]
  22. ' mov ecx,[ebx]
  23. ' mov ebx,[ecx+4]
  24. ' .if eax == 0 && ebx == 0
  25. ' mov eax,1
  26. ' jmp ASM_END
  27. ' .elseif eax == 0 && ebx != 0
  28. ' mov eax,0
  29. ' jmp ASM_END
  30. ' .elseif eax != 0 && ebx == 0
  31. ' mov eax,1
  32. ' jmp ASM_END
  33. ' .elseif ebx > eax
  34. ' mov eax,0
  35. ' jmp ASM_END
  36. ' .endif
  37. ' mov eax,0
  38. ' add edx,8
  39. ' add ecx,8
  40. ' .while eax<ebx
  41. ' push ebx
  42. ' mov bl,[edx+eax]
  43. ' mov bh,[ecx+eax]
  44. ' .if bl != bh
  45. ' mov eax,0
  46. ' pop ebx
  47. ' jmp ASM_END
  48. ' .endif
  49. ' pop ebx
  50. ' inc eax
  51. ' .endw
  52. ' .if eax > 0
  53. ' mov eax,1
  54. ' .elseif
  55. ' mov eax,0
  56. ' .endif
  57. ' ASM_END:
  58. ' leave
  59. ' retn 8

  60. 返回 (假)
复制代码


评分

参与人数 1位币 +36 收起 理由
Cute + 36 神马都是浮云

查看全部评分

相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2018-9-22 09:47:44 | 显示全部楼层
原来是酱紫的,不错不错
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-18 06:26, 3.227.233.55 , Processed in 0.652805 second(s), 33 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表