免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 197|回复: 0
收起左侧

易语言取文本字数 中文全角1字、英文空格1字、换行不计 置入代码全速处理

[复制链接]
发表于 2018-9-22 20:17:53 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A, 文本型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. A = “AAA中文测试 简体中文字符串测试 Hello World!ABC123” + #换行符 + “Test”

  10. 输出调试文本 (取文本字数 (A))



  11. .子程序 取文本字数, 整数型, 公开, 取文本的字数(与字节数不同)中文、全角字符1字 英文字符、空格1字、换行回车不计
  12. .参数 文本数据, 文本型

  13. 置入代码 ({ 139, 93, 8, 138, 101, 16, 139, 27, 185, 0, 0, 0, 0, 186, 0, 0, 0, 0, 138, 3, 10, 192, 117, 4, 235, 21, 235, 16, 60, 128, 114, 3, 65, 235, 9, 60, 13, 116, 5, 60, 10, 116, 1, 66, 67, 235, 227, 209, 233, 3, 202, 139, 193, 201, 194, 4, 0 })
  14. ' mov ebx,[ebp+8]
  15. ' mov ah,[ebp+16]
  16. ' mov ebx,[ebx]
  17. ' mov ecx,0
  18. ' mov edx,0
  19. ' START:
  20. ' mov al,[ebx]
  21. ' .if al == 0
  22. ' jmp ASM_END
  23. ' .elseif al >= 128
  24. ' inc ecx
  25. ' .elseif al != 13 && al != 10
  26. ' inc edx
  27. ' .endif
  28. ' inc ebx
  29. ' JMP START
  30. ' ASM_END:
  31. ' shr ecx,1
  32. ' add ecx,edx
  33. ' mov eax,ecx
  34. ' leave
  35. ' retn 4

  36. 返回 (0)

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 15:55, 34.236.190.216 , Processed in 0.408203 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表