免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 243|回复: 3
收起左侧

易语言置入代码查表返回文本型字符串的方法,通过编号查找并返回多个文本型

[复制链接]
发表于 2018-9-25 10:12:28 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 指针, 整数型
  9. .局部变量 地址, 整数型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. 调试输出 (返回文本 (0))

  12. 调试输出 (返回文本 (1))
  13. 调试输出 (返回文本 (2))
  14. 调试输出 (返回文本 (3))
  15. 调试输出 (返回文本 (4))
  16. 调试输出 (返回文本 (5))
  17. 调试输出 (返回文本 (6))
  18. 调试输出 (返回文本 (7))
  19. 调试输出 (返回文本 (8))




  20. .子程序 返回文本, 文本型
  21. .参数 文本编号, 整数型

  22. 置入代码 ({ 144, 144, 144, 144, 139, 69, 8, 131, 248, 1, 117, 8, 141, 29, 152, 0, 0, 0, 235, 84, 131, 248, 2, 117, 8, 141, 29, 165, 0, 0, 0, 235, 71, 131, 248, 3, 117, 8, 141, 29, 178, 0, 0, 0, 235, 58, 131, 248, 4, 117, 8, 141, 29, 201, 0, 0, 0, 235, 45, 131, 248, 5, 117, 8, 141, 29, 224, 0, 0, 0, 235, 32, 131, 248, 6, 117, 8, 141, 29, 243, 0, 0, 0, 235, 19, 131, 248, 7, 117, 8, 141, 29, 244, 0, 0, 0, 235, 6, 141, 29, 142, 0, 0, 0, 232, 6, 0, 0, 0, 3, 195, 201, 194, 4, 0, 83, 187, 0, 0, 0, 0, 139, 69, 4, 235, 3, 139, 24, 64, 129, 251, 144, 144, 144, 144, 117, 245, 131, 232, 1, 91, 195, 195, 187, 211, 208, 213, 210, 181, 189, 33, 0, 72, 101, 108, 108, 111, 32, 87, 111, 114, 108, 100, 33, 0, 188, 242, 204, 229, 214, 208, 206, 196, 178, 226, 202, 212, 0, 210, 215, 211, 239, 209, 212, 214, 195, 200, 235, 180, 250, 194, 235, 183, 181, 187, 216, 206, 196, 177, 190, 0, 214, 195, 200, 235, 180, 250, 194, 235, 183, 181, 187, 216, 206, 196, 177, 190, 208, 205, 178, 226, 202, 212, 0, 191, 213, 176, 215, 215, 214, 183, 251, 180, 174, 202, 228, 179, 246, 178, 226, 202, 212, 0, 0, 182, 224, 208, 208, 215, 214, 183, 251, 180, 174, 202, 228, 179, 246, 178, 226, 202, 212, 13, 10, 213, 226, 192, 239, 202, 199, 181, 218, 182, 254, 208, 208, 0 })
  23. ' nop
  24. ' nop
  25. ' nop
  26. ' nop
  27. ' mov eax,[ebp+8]
  28. ' .if eax == 1
  29. ' lea ebx,T1
  30. ' .elseif eax == 2
  31. ' lea ebx,T2
  32. ' .elseif eax == 3
  33. ' lea ebx,T3
  34. ' .elseif eax == 4
  35. ' lea ebx,T4
  36. ' .elseif eax == 5
  37. ' lea ebx,T5
  38. ' .elseif eax == 6
  39. ' lea ebx,T6
  40. ' .elseif eax == 7
  41. ' lea ebx,T7
  42. ' .else
  43. ' lea ebx,T0
  44. ' .endif
  45. ' call GET_CODE_ADDRESS
  46. ' add eax,ebx
  47. ' leave
  48. ' retn 4
  49. ' GET_CODE_ADDRESS:
  50. ' push ebx
  51. ' mov ebx,0
  52. ' mov eax,[ebp+4]
  53. ' .while ebx != 90909090H
  54. ' mov ebx,[eax]
  55. ' inc eax
  56. ' .endw
  57. ' sub eax,1
  58. ' pop ebx
  59. ' ret
  60. ' T0 DB "没有找到!",0
  61. ' T1 DB "Hello World!",0
  62. ' T2 DB "简体中文测试",0
  63. ' T3 DB "易语言置入代码返回文本",0
  64. ' T4 DB "置入代码返回文本型测试",0
  65. ' T5 DB "空白字符串输出测试",0
  66. ' T6 DB 0
  67. ' T7 DB "多行字符串输出测试",13,10,"这里是第二行",0

  68. 返回 (“”)
复制代码


相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2018-9-26 08:29:41 | 显示全部楼层
几天没来这里全是置入代码
回复 支持 反对

使用道具 举报

发表于 2018-9-30 16:49:26 | 显示全部楼层
这玩意打包成模块反编译了也没用。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 23:03, 54.198.246.164 , Processed in 0.144537 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表