免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 186|回复: 1
收起左侧

易语言汇编置入代码获取逻辑型数组中真或假的数量 极速获取有多少个真、多少个假

[复制链接]
发表于 2018-9-26 17:05:26 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (逻辑型数组_取真假数量 ({ 真, 假, 真, 假, 真, 假, 假, 假, 真, 真, 真, 真 }, 假))
  10. 调试输出 (逻辑型数组_取真假数量 ({ 真, 假, 真, 假, 真, 假, 假, 假, 真, 真, 真, 真 }, 真))



  11. .子程序 逻辑型数组_取真假数量, 整数型, 公开, 返回逻辑型型数组中有多少个真或多少个假
  12. .参数 逻辑型数组, 逻辑型, 数组
  13. .参数 逻辑值, 逻辑型

  14. 置入代码 ({ 83, 81, 82, 139, 93, 8, 139, 11, 139, 89, 4, 131, 193, 8, 184, 0, 0, 0, 0, 186, 0, 0, 0, 0, 235, 13, 83, 138, 28, 145, 183, 1, 56, 223, 117, 1, 64, 91, 66, 59, 211, 114, 239, 177, 0, 56, 77, 12, 117, 4, 43, 216, 139, 195, 90, 89, 91, 201, 194, 8, 0 })
  15. ' push ebx
  16. ' push ecx
  17. ' push edx
  18. ' mov ebx,[ebp+8]  ;数组地址
  19. ' mov ecx,[ebx]  ;数组数据地址
  20. ' mov ebx,[ecx+4]  ;数组成员数
  21. ' add ecx,8  ;数组数据地址+8
  22. ' mov eax,0  ;返回值
  23. ' mov edx,0  ;数组下标计数
  24. ' .while edx<ebx  ;计数小于成员数则循环
  25. ' push ebx  ;入栈
  26. ' mov bl,[ecx+edx*4] ;从数组中读取逻辑数据
  27. ' mov bh,1
  28. ' .if bh == bl  ;找到1个
  29. ' inc eax  ;数量+1
  30. ' .endif
  31. ' pop ebx   ;出栈
  32. ' inc edx   ;计数+1
  33. ' .endw
  34. ' mov cl,0
  35. ' .if [ebp+12] == cl ;假的数量
  36. ' sub ebx,eax  ;减去数组成员数
  37. ' mov eax,ebx  ;送回返回值
  38. ' .endif
  39. ' pop edx
  40. ' pop ecx
  41. ' pop ebx
  42. ' leave  ;还原某些寄存器的值,否则返回后会出问题
  43. ' retn 8  ;提供了两个参数,每个参数4字节所以这里8


  44. 返回 (0)

复制代码

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
发表于 2018-9-29 10:43:09 | 显示全部楼层
我也来个沙发
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 14:41, 34.236.190.216 , Processed in 0.094726 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表