免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 246|回复: 1
收起左侧

易语言置入代码操作字节集数组/文本型数组例程 实现获取字节集数组/文本型数组总长度

[复制链接]
发表于 2018-10-20 17:57:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 字节集数组, 字节集, , "3"
  8. .局部变量 文本数组, 文本型, , "3"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 字节集数组 [1] = { 1, 2, 3, 4, 5 }
  11. 字节集数组 [2] = { 1, 2, 3, 4, 5, 6, 7, 8, 9, 0 }
  12. 字节集数组 [3] = { 1, 1, 1, 1, 1, 1, 1 }
  13. 文本数组 [1] = “Hello World!”
  14. 文本数组 [2] = “中文测试”
  15. 文本数组 [3] = “----------Test”



  16. 输出调试文本 (取字节集数组长度 (字节集数组))
  17. 输出调试文本 (取文本数组长度 (文本数组))



  18. .子程序 取字节集数组长度, 整数型
  19. .参数 字节集数组, 字节集, 数组

  20. 置入代码 ({ 83, 81, 82, 86, 139, 69, 8, 139, 24, 139, 67, 4, 185, 0, 0, 0, 0, 186, 0, 0, 0, 0, 131, 195, 8, 235, 9, 139, 52, 139, 139, 118, 4, 3, 214, 65, 59, 200, 114, 243, 139, 194, 94, 90, 89, 91, 201, 194, 4, 0 })
  21. ' push ebx
  22. ' push ecx
  23. ' push edx
  24. ' push esi
  25. ' mov eax,[ebp+8]
  26. ' mov ebx,[eax]
  27. ' mov eax,[ebx+4]
  28. ' mov ecx,0
  29. ' mov edx,0
  30. ' add ebx,8
  31. ' .while ecx<eax
  32. ' mov esi,[ebx+ecx*4]
  33. ' mov esi,[esi+4]
  34. ' add edx,esi
  35. ' inc ecx
  36. ' .endw
  37. ' mov eax,edx
  38. ' pop esi
  39. ' pop edx
  40. ' pop ecx
  41. ' pop ebx
  42. ' leave
  43. ' retn 4

  44. 返回 (0)


  45. .子程序 取文本数组长度, 整数型
  46. .参数 文本数组, 文本型, 数组

  47. 置入代码 ({ 83, 81, 82, 86, 139, 69, 8, 139, 24, 139, 67, 4, 185, 0, 0, 0, 0, 186, 0, 0, 0, 0, 131, 195, 8, 235, 26, 139, 52, 139, 80, 83, 187, 0, 0, 0, 0, 138, 4, 51, 10, 192, 117, 2, 235, 4, 66, 67, 235, 243, 91, 88, 65, 59, 200, 114, 226, 139, 194, 94, 90, 89, 91, 201, 194, 4, 0 })
  48. ' push ebx
  49. ' push ecx
  50. ' push edx
  51. ' push esi
  52. ' mov eax,[ebp+8]
  53. ' mov ebx,[eax]
  54. ' mov eax,[ebx+4]
  55. ' mov ecx,0
  56. ' mov edx,0
  57. ' add ebx,8
  58. ' .while ecx<eax
  59. ' mov esi,[ebx+ecx*4]
  60. ' push eax
  61. ' push ebx
  62. ' mov ebx,0
  63. ' TEXT_W:
  64. ' mov al,[esi+ebx]
  65. ' .if al == 0
  66. ' JMP NEXT
  67. ' .endif
  68. ' inc edx
  69. ' inc ebx
  70. ' JMP TEXT_W
  71. ' NEXT:
  72. ' pop ebx
  73. ' pop eax
  74. ' inc ecx
  75. ' .endw
  76. ' mov eax,edx
  77. ' pop esi
  78. ' pop edx
  79. ' pop ecx
  80. ' pop ebx
  81. ' leave
  82. ' retn 4

  83. 返回 (0)

复制代码

回复

使用道具 举报

腾讯云为数百万企业和开发者提供安全、稳定的云服务器、云数据库、CDN等云服务
发表于 2018-10-21 09:09:42 | 显示全部楼层
路过谢谢发
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 14:32, 34.236.190.216 , Processed in 0.187500 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表