免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 106|回复: 0
收起左侧

易语言编辑框仿LED显示屏循环左右移走马灯走字特效支持中英文混合

[复制链接]
发表于 2018-11-4 21:33:19 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 窗口程序集_启动窗口

  3. .子程序 __启动窗口_创建完毕

  4. 移位.时钟周期 = 100
  5. 编辑框1.内容 = “易语言编辑框仿LED显示屏循环左右移走马灯走字特效支持中英文混合 Hello World!”

  6. .子程序 _移位_周期事件
  7. .局部变量 文本, 文本型
  8. .局部变量 字节集, 字节集
  9. .局部变量 移出的字, 文本型
  10. .局部变量 字长, 整数型
  11. .局部变量 左右移, 逻辑型, 静态
  12. .局部变量 总长, 整数型
  13. .局部变量 计数, 整数型, 静态

  14. 计数 = 计数 + 1
  15. .如果真 (计数 ≥ 200)
  16.     计数 = 0
  17.     左右移 = 取反 (左右移)
  18. .如果真结束
  19. 字节集 = 到字节集 (编辑框1.内容)
  20. 总长 = 取字节集长度 (字节集)
  21. .如果真 (左右移)
  22.     字长 = 选择 (字节集 [1] ≥ 128, 2, 1)
  23.     移出的字 = 取文本左边 (编辑框1.内容, 字长)
  24.     编辑框1.内容 = 取文本右边 (编辑框1.内容, 总长 - 字长) + 移出的字
  25.     返回 ()
  26. .如果真结束

  27. 字长 = 选择 (字节集 [总长] ≥ 128, 2, 1)
  28. 移出的字 = 取文本右边 (编辑框1.内容, 字长)

  29. 编辑框1.内容 = 移出的字 + 取文本左边 (编辑框1.内容, 总长 - 字长)
复制代码


相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 23:29, 54.198.246.164 , Processed in 0.140628 second(s), 28 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表