免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 284|回复: 4
收起左侧

易语言实现英文字母转换到九宫格键盘数字(不区分大小写)

[复制链接]
发表于 2018-11-20 17:45:07 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x


  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (英文字母到九宫格数字 (“iloveyou”))
  9. 输出调试文本 (英文字母到九宫格数字 (“helloworld”))



  10. .子程序 英文字母到九宫格数字, 文本型, , 不支持中文、符号、空格(不区分大小写)
  11. .参数 英文字母, 文本型
  12. .局部变量 计数, 整数型
  13. .局部变量 代码, 字节型
  14. .局部变量 字节数组, 字节型, , "0"
  15. .局部变量 长度, 整数型

  16. 英文字母 = 到小写 (英文字母)
  17. 长度 = 取文本长度 (英文字母)
  18. 重定义数组 (字节数组, 假, 长度)
  19. .计次循环首 (长度, 计数)
  20.     代码 = 取代码 (英文字母, 计数)
  21.     .判断开始 (代码 ≥ 97 且 代码 ≤ 99)
  22.         字节数组 [计数] = 50
  23.     .判断 (代码 ≥ 100 且 代码 ≤ 102)
  24.         字节数组 [计数] = 51
  25.     .判断 (代码 ≥ 103 且 代码 ≤ 105)
  26.         字节数组 [计数] = 52
  27.     .判断 (代码 ≥ 106 且 代码 ≤ 108)
  28.         字节数组 [计数] = 53
  29.     .判断 (代码 ≥ 109 且 代码 ≤ 111)
  30.         字节数组 [计数] = 54
  31.     .判断 (代码 ≥ 112 且 代码 ≤ 115)
  32.         字节数组 [计数] = 55
  33.     .判断 (代码 ≥ 116 且 代码 ≤ 118)
  34.         字节数组 [计数] = 56
  35.     .判断 (代码 ≥ 119 且 代码 ≤ 122)
  36.         字节数组 [计数] = 57
  37.     .默认
  38.         字节数组 [计数] = 48
  39.     .判断结束

  40. .计次循环尾 ()
  41. 返回 (到文本 (字节数组))



复制代码

相关帖子

回复

使用道具 举报

腾讯云服务器安全可靠高性能,多种配置供您选择
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 01:07, 100.26.182.28 , Processed in 1.460803 second(s), 27 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表