设为首页收藏本站CRC32解密2.0更改用户名领夜猫子 本站已运行
搜索
查看: 49|回复: 1
收起左侧

易语言实现取括号内的文本并放入数组,(设计编译器专用,括号外的不会放入) 支持转义符

[复制链接]
发表于 2018-11-27 08:52:31 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
[code]
.版本 2
.支持库 spec

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 可以根据您的需要返回任意数值

.子程序 _临时子程序
.局部变量 文本, 文本型, , "0"

' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
取括号内文本数组 (“ABC(123)(4\(56\))不会显示(会显示\))”, 文本)
调试输出 (文本)


.子程序 取括号内文本数组, 逻辑型, 公开, 易语言实现取括号内的文本并放入数组(支持转义,括号外的不会放入)
.参数 文本, 文本型, , 括号必须对称使用否则将失败
.参数 括号文本, 文本型, 数组

.如果真 (取括号内文本数组_ (文本, 括号文本) = 假)
    重定义数组 (括号文本, 假, 0)
    返回 (假)
.如果真结束
返回 (真)

.子程序 取括号内文本数组_, 逻辑型
.参数 文本, 文本型
.参数 括号文本, 文本型, 数组
.局部变量 计数, 整数型
.局部变量 代码, 整数型
.局部变量 括号内, 逻辑型
.局部变量 括号内文本, 文本型
.局部变量 括号, 逻辑型

重定义数组 (括号文本, 假, 0)
.计次循环首 (取文本长度 (文本), 计数)
    代码 = 取代码 (文本, 计数)
    .如果 (取代码 (文本, 计数 - 1) ≠ 92)
        .判断开始 (代码 = 40)
            括号 = 真
            .如果真 (括号内)
                返回 (假)
            .如果真结束
            括号内 = 真
        .判断 (代码 = 41)  ' )
            括号 = 真
            .如果真 (括号内 = 假)
                返回 (假)
            .如果真结束
            括号内 = 假
            括号内文本 = 子文本替换 (括号内文本, “\)”, “)”, , , 真)
            括号内文本 = 子文本替换 (括号内文本, “\(”, “(”, , , 真)
            加入成员 (括号文本, 括号内文本)
            括号内文本 = “”
        .默认
            括号 = 假
        .判断结束

    .否则
        括号 = 假
    .如果结束
    .如果真 (括号内 且 括号 = 假)
        括号内文本 = 括号内文本 + 字符 (代码)
    .如果真结束

.计次循环尾 ()
返回 (括号内 = 假)
[/code]

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2018-12-23 10:50:38 | 显示全部楼层
路过帮顶
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

关闭

站长推荐上一条 /1 下一条

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )  

蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-2-21 13:49 , Processed in 0.062499 second(s), 26 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表