设为首页收藏本站CRC32解密2.0更改用户名回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 94|回复: 2
收起左侧

删引号外全部空的处理函数(用于删除代码中无用的空格,引号内为文本不处理)编译器专用

[复制链接]
发表于 2018-11-27 18:13:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  8. 输出调试文本 (删引号外全部空 (“funtion('Hello World!') ? true : false;”, 真))
  9. 输出调试文本 (删引号外全部空 (“Hello World!”, 真))

  10. .子程序 删引号外全部空, 文本型, 公开, 用于删除代码中多余的空格(引号内为文本字符串不做处理)
  11. .参数 欲删除空格的文本, 文本型, , 不支持转义符否则将出错
  12. .参数 单双引号, 逻辑型, 可空, 真为单引号,假为双引号
  13. .局部变量 数组, 文本型, , "0"
  14. .局部变量 计数, 整数型
  15. .局部变量 返回值, 文本型
  16. .局部变量 成员数, 整数型
  17. .局部变量 结尾引号, 逻辑型
  18. .局部变量 引号符, 文本型
  19. .局部变量 引号符代码, 字节型

  20. 引号符 = 选择 (单双引号, “'”, #引号)
  21. 引号符代码 = 取代码 (引号符, )
  22. 数组 = 分割文本 (欲删除空格的文本, 引号符, )
  23. 成员数 = 取数组成员数 (数组)
  24. .计次循环首 (成员数, 计数)
  25.     .如果真 (位与 (计数, 1) = 1)
  26.         数组 [计数] = 删全部空 (数组 [计数])
  27.     .如果真结束
  28.     返回值 = 返回值 + 选择 (成员数 = 计数 且 取代码 (欲删除空格的文本, 取文本长度 (欲删除空格的文本)) ≠ 引号符代码, 数组 [计数], 数组 [计数] + 引号符)
  29. .计次循环尾 ()

  30. 返回 (返回值)

复制代码

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2018-11-27 18:33:36 | 显示全部楼层
6666
回复 支持 反对

使用道具 举报

发表于 2018-12-23 10:50:22 | 显示全部楼层
最近好像不少编译器的帖子
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-5-20 16:27, 3.80.223.123 , Processed in 0.078125 second(s), 24 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表