设为首页收藏本站CRC32解密2.0更改用户名领夜猫子 本站已运行
搜索
查看: 81|回复: 8
收起左侧

写入0x5A(90) 再写入 0xA5(165) 后返回真 写入别的或不按顺序写则返回假的实现方法

[复制链接]
发表于 2019-1-6 18:18:43 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
[code]
.版本 2
.支持库 spec
.程序集 程序集1
.子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 可以根据您的需要返回任意数值
.子程序 _临时子程序
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
调试输出 (检测5AA5 (90))
调试输出 (检测5AA5 (165))
调试输出 (检测5AA5 (90))
调试输出 (检测5AA5 (165))

.子程序 检测5AA5, 逻辑型, 公开, 写入0x5A(90) 再写入 0xA5(165) 后返回真 写入别的或不按顺序写则返回假
.参数 值, 字节型
.局部变量 已写入5A, 逻辑型, 静态
.判断开始 (值 ≠ 90 且 值 ≠ 165)
    已写入5A = 假
    返回 (假)
.判断 (已写入5A = 假 且 值 = 90)
    已写入5A = 真
    返回 (假)
.判断 (已写入5A 且 值 = 165)
    已写入5A = 假
    返回 (真)
.默认
.判断结束
已写入5A = 假
返回 (假)
[/code]

回复

使用道具 举报

腾讯云为数百万企业和开发者提供安全、稳定的云服务器、云数据库、CDN等云服务
发表于 2019-1-6 20:19:00 | 显示全部楼层
够水的啊
回复 支持 反对

使用道具 举报

发表于 2019-1-7 09:33:58 | 显示全部楼层
看不懂哪里用的
回复 支持 反对

使用道具 举报

发表于 2019-1-7 10:26:30 | 显示全部楼层
666
回复 支持 反对

使用道具 举报

发表于 2019-1-8 09:56:02 | 显示全部楼层
路过打酱油
回复 支持 反对

使用道具 举报

发表于 2019-1-8 10:06:40 | 显示全部楼层
顶一下子吧
回复 支持 反对

使用道具 举报

发表于 2019-1-8 16:46:14 | 显示全部楼层
必须的顶
回复 支持 反对

使用道具 举报

发表于 2019-1-8 18:52:02 | 显示全部楼层
4面8方 发表于 2019-1-7 09:33
看不懂哪里用的

校验用的
回复 支持 反对

使用道具 举报

发表于 2019-1-10 20:13:48 | 显示全部楼层
神逻辑操作
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )

蒙公网安备 15010402000325号

腾讯云安全认证

GMT+8, 2019-4-22 20:07, 18.212.239.56 , Processed in 0.062500 second(s), 29 queries .

Powered by Discuz! X3.4 Licensed © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表