免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 156|回复: 7
收起左侧

易语言窗口全屏程序代码 选择框控制启动窗口是否全屏显示并总在最前

[复制链接]
发表于 2019-1-23 10:42:01 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 窗口程序集_启动窗口

  3. .子程序 __启动窗口_创建完毕

  4. 标题 = “易语言全屏程序”
  5. 选择框1.标题 = “全屏”
  6. 选择框1.左边 = 8
  7. 选择框1.顶边 = 8
  8. 选择框1.宽度 = 48
  9. 选择框1.高度 = 24


  10. .子程序 全屏, 逻辑型
  11. .参数 进入全屏, 逻辑型
  12. .局部变量 记忆宽, 整数型, 静态
  13. .局部变量 记忆高, 整数型, 静态
  14. .局部变量 记忆左, 整数型, 静态
  15. .局部变量 记忆顶, 整数型, 静态
  16. .局部变量 记忆边框, 整数型, 静态
  17. .局部变量 记忆最前, 逻辑型, 静态
  18. .局部变量 全屏状态, 逻辑型, 静态

  19. .如果 (进入全屏)
  20.     .如果真 (全屏状态)
  21.         返回 (假)
  22.     .如果真结束
  23.     全屏状态 = 真
  24.     记忆宽 = 宽度
  25.     记忆高 = 高度
  26.     记忆左 = 左边
  27.     记忆顶 = 顶边
  28.     记忆边框 = 边框
  29.     记忆最前 = 总在最前
  30.     边框 = 0
  31.     左边 = 0
  32.     顶边 = 0
  33.     宽度 = 取屏幕宽度 ()
  34.     高度 = 取屏幕高度 ()
  35.     总在最前 = 真
  36.     返回 (真)

  37. .否则
  38.     .如果真 (全屏状态 = 假)
  39.         返回 (假)
  40.     .如果真结束
  41.     全屏状态 = 假

  42.     宽度 = 记忆宽
  43.     高度 = 记忆高
  44.     左边 = 记忆左
  45.     顶边 = 记忆顶
  46.     边框 = 记忆边框
  47.     总在最前 = 记忆最前
  48.     返回 (真)


  49. .如果结束



  50. .子程序 _选择框1_被单击

  51. 检查 (全屏 (选择框1.选中))
复制代码


相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2019-1-23 11:52:09 | 显示全部楼层
这个比较菜
回复 支持 反对

使用道具 举报

发表于 2019-1-24 11:08:33 | 显示全部楼层
顶顶顶顶顶顶顶
回复 支持 反对

使用道具 举报

发表于 2019-1-24 11:08:35 | 显示全部楼层
顶顶顶顶顶顶顶
回复 支持 反对

使用道具 举报

发表于 2019-1-25 11:54:31 | 显示全部楼层
顶顶顶顶顶顶顶
回复 支持 反对

使用道具 举报

发表于 2019-1-26 10:39:34 | 显示全部楼层
顶顶顶顶顶
回复 支持 反对

使用道具 举报

发表于 2019-4-12 19:56:19 来自手机 | 显示全部楼层
顶顶顶顶顶顶顶
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 01:09, 100.26.182.28 , Processed in 0.995803 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表