免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 161|回复: 4
收起左侧

易语言检测当前系统中的整数型在内存中/到字节集后大小端的存储状态是大端或是小端

[复制链接]
发表于 2019-1-27 20:29:54 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. .如果 (取大小端 ())
  8.     输出调试文本 (“大端存储”)
  9. .否则
  10.     输出调试文本 (“小端存储”)
  11. .如果结束



  12. .子程序 取大小端, 逻辑型, 公开, 大端存储(高字节在前)返回真 小端存储(低字节在前)返回假
  13. .局部变量 临时字节集, 字节集

  14. 临时字节集 = 到字节集 (到整数 (1234567890))
  15. .判断开始 (临时字节集 = { 210, 2, 150, 73 })
  16.     返回 (假)
  17. .判断 (临时字节集 = { 73, 150, 2, 210 })
  18.     返回 (真)
  19. .默认

  20. .判断结束
  21. 暂停 ()
  22. 返回 (假)
复制代码


相关帖子

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
发表于 2019-1-27 21:12:49 | 显示全部楼层
我还是路过好了
回复 支持 反对

使用道具 举报

发表于 2019-1-28 08:32:20 | 显示全部楼层
我勒个去,多发这种水帖
回复 支持 反对

使用道具 举报

发表于 2019-2-4 00:20:43 | 显示全部楼层
我也留下痕迹
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 00:43, 100.26.182.28 , Processed in 0.633002 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表