免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子领6月福利帮助中心 本站已运行
搜索
查看: 77|回复: 2
收起左侧

易语言实现整数型数组、索引数组的JSON文本编码与解码

[复制链接]
发表于 2019-3-2 18:24:28 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 文本型
  9. .局部变量 b, 整数型, , "0"

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. A = “[1,2,3,4,5,6,7,8,9,222,33333,-1]”

  12. JSON解码_整数型索引数组 (A, b)

  13. 调试输出 (A, b, JSON编码_整数型索引数组 ({ 12345, -54321, 1234567890, -1234567890 }))

  14. .子程序 JSON编码_整数型索引数组, 文本型, 公开, 编码结果返回JSON文本
  15. .参数 整数数组, 整数型, 数组
  16. .局部变量 文件号, 整数型
  17. .局部变量 返回值, 文本型
  18. .局部变量 计数, 整数型

  19. 文件号 = 打开内存文件 ()
  20. 写出文本 (文件号, “[”)
  21. .计次循环首 (取数组成员数 (整数数组) - 1, 计数)
  22.     写出文本 (文件号, 整数数组 [计数])
  23.     写出文本 (文件号, “,”)
  24. .计次循环尾 ()
  25. 写出文本 (文件号, 整数数组 [计数])
  26. 写出文本 (文件号, “]”)
  27. 移动读写位置 (文件号, 1, 0)
  28. 返回值 = 读入文本 (文件号, )
  29. 关闭文件 (文件号)
  30. 返回 (返回值)


  31. .子程序 JSON解码_整数型索引数组, 逻辑型, 公开, 成功返回真 失败返回假
  32. .参数 JSON文本, 文本型, , 提供JSON文本
  33. .参数 整数数组输出, 整数型, 参考 数组, 结果通过数组传出
  34. .局部变量 分割结果, 文本型, , "0"
  35. .局部变量 分割数量, 整数型
  36. .局部变量 计数, 整数型

  37. .如果真 (取文本左边 (JSON文本, 1) ≠ “[” 或 取文本右边 (JSON文本, 1) ≠ “]”)
  38.     返回 (假)
  39. .如果真结束
  40. 分割结果 = 分割文本 (取文本中间 (JSON文本, 2, 取文本长度 (JSON文本) - 2), “,”, )
  41. 分割数量 = 取数组成员数 (分割结果)
  42. 重定义数组 (整数数组输出, 假, 分割数量)
  43. .计次循环首 (分割数量, 计数)
  44.     整数数组输出 [计数] = 到整数 (分割结果 [计数])
  45. .计次循环尾 ()
  46. 返回 (真)

复制代码


回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2019-3-2 19:08:01 | 显示全部楼层
顶顶顶顶顶
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-6-25 08:04, 54.226.30.186 , Processed in 0.093751 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表