设为首页收藏本站帮助中心
查看: 590|回复: 4
收起左侧

取随机文本型字符串/随机密码2.0版 优化执行效率 (可指定:数字/大写/小写/符号/空格)

[复制链接]
发表于 2019-3-10 11:02:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x


  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  4. 置随机数种子 ()
  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 时间, 整数型
  9. .局部变量 文本, 文本型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. 时间 = 取启动时间 ()

  12. 文本 = 取随机文本 (100000, 真, 真, 真, 真, )

  13. 输出调试文本 (取启动时间 () - 时间)
  14. 输出调试文本 (取随机文本 (1000, 真, 真, 真, 真, ))

  15. .子程序 取随机文本, 文本型, 公开
  16. .参数 长度, 整数型
  17. .参数 允许数字, 逻辑型, 可空
  18. .参数 允许大写, 逻辑型, 可空
  19. .参数 允许小写, 逻辑型, 可空
  20. .参数 允许符号, 逻辑型, 可空
  21. .参数 允许空格, 逻辑型, 可空
  22. .局部变量 返回值, 字节型, , "0"
  23. .局部变量 类型, 字节型
  24. .局部变量 字符码, 字节型

  25. .如果真 (长度 < 1 或 允许数字 = 假 且 允许大写 = 假 且 允许小写 = 假 且 允许符号 = 假 且 允许空格 = 假)
  26.     返回 (“”)
  27. .如果真结束
  28. .循环判断首 ()
  29.     类型 = 取随机数 (0, 4)
  30.     .判断开始 (类型 = 0)
  31.         .如果 (允许数字)
  32.             字符码 = 取随机数 (48, 57)
  33.         .否则
  34.             到循环尾 ()
  35.         .如果结束

  36.     .判断 (类型 = 1)
  37.         .如果 (允许大写)
  38.             字符码 = 取随机数 (65, 90)
  39.         .否则
  40.             到循环尾 ()
  41.         .如果结束

  42.     .判断 (类型 = 2)
  43.         .如果 (允许小写)
  44.             字符码 = 取随机数 (97, 122)
  45.         .否则
  46.             到循环尾 ()
  47.         .如果结束

  48.     .判断 (类型 = 3)
  49.         .如果 (允许符号)
  50.             类型 = 取随机数 (0, 3)
  51.             .判断开始 (类型 = 0)
  52.                 字符码 = 取随机数 (33, 47)
  53.             .判断 (类型 = 1)
  54.                 字符码 = 取随机数 (58, 64)
  55.             .判断 (类型 = 2)
  56.                 字符码 = 取随机数 (91, 96)
  57.             .判断 (类型 = 3)
  58.                 字符码 = 取随机数 (123, 126)
  59.             .默认

  60.             .判断结束

  61.         .否则
  62.             到循环尾 ()
  63.         .如果结束

  64.     .判断 (类型 = 4)
  65.         .如果 (允许空格)
  66.             字符码 = 32
  67.         .否则
  68.             到循环尾 ()
  69.         .如果结束

  70.     .默认

  71.     .判断结束
  72.     加入成员 (返回值, 字符码)
  73. .循环判断尾 (取数组成员数 (返回值) < 长度)
  74. 返回 (到文本 (返回值))



复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则