免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 88|回复: 0
收起左侧

易语言控制台调用chcp自动获取活动代码页,自动选择输出语言防止乱码

[复制链接]
发表于 2019-3-19 22:02:08 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x


  1. .版本 2
  2. .程序集 程序集1
  3. .子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
  4. .局部变量 代码页, 整数型
  5. 代码页 = 取代码页 ()
  6. .判断开始 (代码页 = 936)
  7.     控制台输出 (“你好,世界!”)
  8. .默认
  9.     控制台输出 (“Hello World!”)
  10. .判断结束
  11. 返回 (0)  ' 可以根据您的需要返回任意数值
  12. .子程序 取代码页, 整数型, 公开
  13. .局部变量 临时文件名, 文本型
  14. .局部变量 返回文本, 文本型, , "0"
  15. 临时文件名 = 取临时文件名 ()
  16. .如果真 (运行 (“cmd /c chcp >” + 临时文件名, 真, 1) = 假)
  17.     返回 (0)
  18. .如果真结束
  19. 返回文本 = 分割文本 (到文本 (读入文件 (临时文件名)), “:”, )
  20. 删除文件 (临时文件名)
  21. 返回 (到整数 (返回文本 [2]))
  22. .子程序 控制台输出
  23. .参数 文本, 文本型
  24. 标准输出 (, 文本 + #换行符)

复制代码


相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 14:37, 34.236.190.216 , Processed in 0.078125 second(s), 28 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表