免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 82|回复: 2
收起左侧

易语言实现 foreach 循环遍历整数型数组并调用子程序指针提供索引/键值

[复制链接]
发表于 2019-3-23 21:59:20 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 检查 (foreach ({ 2, 4, 6, 8, 10, 12345, 234567890, 2147483647 }, &回调钩子))


  10. .子程序 foreach, 逻辑型, 公开
  11. .参数 整数数组, 整数型, 数组
  12. .参数 回调钩子, 子程序指针, , 参数1:索引 参数2:键值
  13. .局部变量 索引, 整数型

  14. .计次循环首 (取数组成员数 (整数数组), 索引)
  15.     .如果真 (调用子程序 (回调钩子, , , 索引, 整数数组 [索引]) = 假)
  16.         返回 (假)
  17.     .如果真结束

  18. .计次循环尾 ()
  19. 返回 (真)

  20. .子程序 回调钩子
  21. .参数 索引, 整数型
  22. .参数 键值, 整数型

  23. 调试输出 (索引, 键值)



复制代码

相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:06, 107.23.37.199 , Processed in 0.078127 second(s), 37 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表