免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 90|回复: 1
收起左侧

易语言检测数值数组有多少负数 (支持:整数型,短整数型,长整数型,小数型,双精度小数型)

[复制链接]
发表于 2019-3-29 17:24:46 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (整数型_数组有多少个负数 ({ 0, 1, 2, 3, 4, 5, -1, 2, 3, 4, 5, 6, 7, 9, 0, 1, -2, -3 }))


  9. .子程序 整数型_数组有多少个负数, 整数型, 公开
  10. .参数 数组, 整数型, 数组
  11. .局部变量 返回值, 整数型
  12. .局部变量 计数, 整数型

  13. .计次循环首 (取数组成员数 (数组), 计数)
  14.     .如果真 (数组 [计数] < 0)
  15.         返回值 = 返回值 + 1
  16.     .如果真结束

  17. .计次循环尾 ()
  18. 返回 (返回值)

  19. .子程序 短整数型_数组有多少个负数, 整数型, 公开
  20. .参数 数组, 短整数型, 数组
  21. .局部变量 返回值, 整数型
  22. .局部变量 计数, 整数型

  23. .计次循环首 (取数组成员数 (数组), 计数)
  24.     .如果真 (数组 [计数] < 0)
  25.         返回值 = 返回值 + 1
  26.     .如果真结束

  27. .计次循环尾 ()
  28. 返回 (返回值)



  29. .子程序 长整数型_数组有多少个负数, 整数型, 公开
  30. .参数 数组, 长整数型, 数组
  31. .局部变量 返回值, 整数型
  32. .局部变量 计数, 整数型

  33. .计次循环首 (取数组成员数 (数组), 计数)
  34.     .如果真 (数组 [计数] < 0)
  35.         返回值 = 返回值 + 1
  36.     .如果真结束

  37. .计次循环尾 ()
  38. 返回 (返回值)



  39. .子程序 小数型_数组有多少个负数, 整数型, 公开
  40. .参数 数组, 小数型, 数组
  41. .局部变量 返回值, 整数型
  42. .局部变量 计数, 整数型

  43. .计次循环首 (取数组成员数 (数组), 计数)
  44.     .如果真 (数组 [计数] < 0)
  45.         返回值 = 返回值 + 1
  46.     .如果真结束

  47. .计次循环尾 ()
  48. 返回 (返回值)



  49. .子程序 双精度小数型_数组有多少个负数, 整数型, 公开
  50. .参数 数组, 双精度小数型, 数组
  51. .局部变量 返回值, 整数型
  52. .局部变量 计数, 整数型

  53. .计次循环首 (取数组成员数 (数组), 计数)
  54.     .如果真 (数组 [计数] < 0)
  55.         返回值 = 返回值 + 1
  56.     .如果真结束

  57. .计次循环尾 ()
  58. 返回 (返回值)


复制代码

相关帖子

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-18 06:49, 3.227.233.55 , Processed in 0.583417 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表