免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 94|回复: 2
收起左侧

超简单的浮点小数编解码算法易语言实现 (将小数编解码为二进制字节集,支持负数符号)

[复制链接]
发表于 2019-4-20 19:10:29 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x


  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 编码后, 字节集

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 编码后 = 小数编码 (3.1415926)
  11. 调试输出 (编码后)
  12. 调试输出 (小数解码 (编码后))



  13. .子程序 小数编码, 字节集, 公开, 将小数编码成字节集 失败返回空字节集
  14. .参数 小数, 小数型
  15. .局部变量 整数部分, 整数型
  16. .局部变量 小数部分, 小数型

  17. 整数部分 = 到整数 (小数)
  18. .如果真 (整数部分 ≠ 到长整数 (小数))
  19.     返回 ({  })
  20. .如果真结束
  21. 小数部分 = 小数 - 整数部分
  22. 返回 (到字节集 (整数部分) + 到字节集 (到整数 (小数部分 × 2147483647)))

  23. .子程序 小数解码, 小数型, 公开, 将字节集解码成小数
  24. .参数 字节集, 字节集
  25. .局部变量 整数部分, 整数型
  26. .局部变量 小数部分, 小数型

  27. 整数部分 = 取字节集数据 (取字节集左边 (字节集, 4), 3, )
  28. 小数部分 = 取字节集数据 (取字节集右边 (字节集, 4), 3, ) ÷ 2147483647
  29. 返回 (整数部分 + 小数部分)


复制代码

相关帖子

回复

使用道具 举报

腾讯云为数百万企业和开发者提供安全、稳定的云服务器、云数据库、CDN等云服务
发表于 2019-4-20 23:36:23 | 显示全部楼层
这个范围正负21亿,和ieee不是同一个算法。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-18 06:48, 3.227.233.55 , Processed in 0.372801 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表