更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言实现将单维数组成员随机打乱(洗牌)模块源码V1.0 - 兼容所有基本数据类型

[复制链接]
查看93 | 回复3 | 2019-6-16 16:14:30 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x


  1. .版本 2
  2. .支持库 spec

  3. .程序集 数组洗牌, , , 将数组成员随机打乱

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  5. 置随机数种子 ()
  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 A, 整数型, , "0"

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  11. A = { 0.1, 2, 3, 4, 5, 6, 7, 8, 9, 10 }
  12. 调试输出 (A)
  13. 整数型_数组洗牌 (A)
  14. 调试输出 (A)

  15. .子程序 字节型_数组洗牌, , 公开
  16. .参数 数组, 字节型, 参考 数组
  17. .局部变量 下标, 整数型
  18. .局部变量 数组2, 字节型, , "0"

  19. .判断循环首 (取数组成员数 (数组) ≠ 0)
  20.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  21.     加入成员 (数组2, 数组 [下标])
  22.     删除成员 (数组, 下标, 1)
  23. .判断循环尾 ()
  24. 数组 = 数组2

  25. .子程序 整数型_数组洗牌, , 公开
  26. .参数 数组, 整数型, 参考 数组
  27. .局部变量 下标, 整数型
  28. .局部变量 数组2, 整数型, , "0"

  29. .判断循环首 (取数组成员数 (数组) ≠ 0)
  30.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  31.     加入成员 (数组2, 数组 [下标])
  32.     删除成员 (数组, 下标, 1)
  33. .判断循环尾 ()
  34. 数组 = 数组2

  35. .子程序 小数型_数组洗牌, , 公开
  36. .参数 数组, 小数型, 参考 数组
  37. .局部变量 下标, 整数型
  38. .局部变量 数组2, 小数型, , "0"

  39. .判断循环首 (取数组成员数 (数组) ≠ 0)
  40.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  41.     加入成员 (数组2, 数组 [下标])
  42.     删除成员 (数组, 下标, 1)
  43. .判断循环尾 ()
  44. 数组 = 数组2

  45. .子程序 逻辑型_数组洗牌, , 公开
  46. .参数 数组, 逻辑型, 参考 数组
  47. .局部变量 下标, 整数型
  48. .局部变量 数组2, 逻辑型, , "0"

  49. .判断循环首 (取数组成员数 (数组) ≠ 0)
  50.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  51.     加入成员 (数组2, 数组 [下标])
  52.     删除成员 (数组, 下标, 1)
  53. .判断循环尾 ()
  54. 数组 = 数组2

  55. .子程序 文本型_数组洗牌, , 公开
  56. .参数 数组, 文本型, 参考 数组
  57. .局部变量 下标, 整数型
  58. .局部变量 数组2, 文本型, , "0"

  59. .判断循环首 (取数组成员数 (数组) ≠ 0)
  60.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  61.     加入成员 (数组2, 数组 [下标])
  62.     删除成员 (数组, 下标, 1)
  63. .判断循环尾 ()
  64. 数组 = 数组2

  65. .子程序 字节集_数组洗牌, , 公开
  66. .参数 数组, 字节集, 参考 数组
  67. .局部变量 下标, 整数型
  68. .局部变量 数组2, 字节集, , "0"

  69. .判断循环首 (取数组成员数 (数组) ≠ 0)
  70.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  71.     加入成员 (数组2, 数组 [下标])
  72.     删除成员 (数组, 下标, 1)
  73. .判断循环尾 ()
  74. 数组 = 数组2

  75. .子程序 短整数型_数组洗牌, , 公开
  76. .参数 数组, 短整数型, 参考 数组
  77. .局部变量 下标, 整数型
  78. .局部变量 数组2, 短整数型, , "0"

  79. .判断循环首 (取数组成员数 (数组) ≠ 0)
  80.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  81.     加入成员 (数组2, 数组 [下标])
  82.     删除成员 (数组, 下标, 1)
  83. .判断循环尾 ()
  84. 数组 = 数组2

  85. .子程序 长整数型_数组洗牌, , 公开
  86. .参数 数组, 长整数型, 参考 数组
  87. .局部变量 下标, 整数型
  88. .局部变量 数组2, 长整数型, , "0"

  89. .判断循环首 (取数组成员数 (数组) ≠ 0)
  90.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  91.     加入成员 (数组2, 数组 [下标])
  92.     删除成员 (数组, 下标, 1)
  93. .判断循环尾 ()
  94. 数组 = 数组2

  95. .子程序 日期时间型_数组洗牌, , 公开
  96. .参数 数组, 日期时间型, 参考 数组
  97. .局部变量 下标, 整数型
  98. .局部变量 数组2, 日期时间型, , "0"

  99. .判断循环首 (取数组成员数 (数组) ≠ 0)
  100.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  101.     加入成员 (数组2, 数组 [下标])
  102.     删除成员 (数组, 下标, 1)
  103. .判断循环尾 ()
  104. 数组 = 数组2

  105. .子程序 子程序指针_数组洗牌, , 公开
  106. .参数 数组, 子程序指针, 参考 数组
  107. .局部变量 下标, 整数型
  108. .局部变量 数组2, 子程序指针, , "0"

  109. .判断循环首 (取数组成员数 (数组) ≠ 0)
  110.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  111.     加入成员 (数组2, 数组 [下标])
  112.     删除成员 (数组, 下标, 1)
  113. .判断循环尾 ()
  114. 数组 = 数组2

  115. .子程序 双精度小数型_数组洗牌, , 公开
  116. .参数 数组, 双精度小数型, 参考 数组
  117. .局部变量 下标, 整数型
  118. .局部变量 数组2, 双精度小数型, , "0"

  119. .判断循环首 (取数组成员数 (数组) ≠ 0)
  120.     下标 = 取随机整数 (1, 取数组成员数 (数组))
  121.     加入成员 (数组2, 数组 [下标])
  122.     删除成员 (数组, 下标, 1)
  123. .判断循环尾 ()
  124. 数组 = 数组2

  125. .子程序 限制整数范围, 整数型
  126. .参数 数值, 整数型
  127. .参数 最大值, 整数型
  128. .参数 最小值, 整数型
  129. .局部变量 无符号数值, 长整数型
  130. .局部变量 无符号最大值, 长整数型
  131. .局部变量 无符号最小值, 长整数型
  132. .局部变量 无符号答案, 长整数型

  133. .如果真 (最大值 < 最小值)
  134.     交换变量 (最大值, 最小值)
  135. .如果真结束
  136. 无符号数值 = 数值 + 2147483648
  137. 无符号最大值 = 最大值 + 2147483648
  138. 无符号最小值 = 最小值 + 2147483648
  139. 无符号答案 = 无符号数值 % (无符号最大值 - 无符号最小值 + 1) + 无符号最小值
  140. 返回 (无符号答案 - 2147483648)

  141. .子程序 取随机整数, 整数型, , 取随机整数 范围 -2147483648~2147483647
  142. .参数 最大值, 整数型, , 支持负数
  143. .参数 最小值, 整数型
  144. .局部变量 字节集, 字节集
  145. .局部变量 计数, 整数型
  146. .局部变量 整数, 整数型

  147. 字节集 = 取空白字节集 (4)
  148. .计次循环首 (4, 计数)
  149.     字节集 [计数] = 取随机数 (, )
  150. .计次循环尾 ()
  151. 返回 (限制整数范围 (取字节集数据 (字节集, #整数型, 1), 最大值, 最小值))


复制代码

相关帖子

回复

使用道具 举报

小莉今年7岁 | 2019-6-17 11:16:53 | 显示全部楼层

你这到底是人还是机器
回复 支持 反对

使用道具 举报

1心1亿 | 2019-7-10 12:24:17 | 显示全部楼层
啧啧啧 发表于 2019-6-17 11:16
你这到底是人还是机器

你猜
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则