更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 161|回复: 3
收起左侧

易语言置入代码实现字节集数据的ROT13算法极速编码加密(字母回转13位,不分大小写)

[复制链接]
发表于 2019-6-30 18:19:34 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A, 字节集

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. A = 到字节集 (“Hello World! ABCabc中文测试”)

  10. 字节集_ROT13 (A)
  11. 输出调试文本 (到文本 (A))



  12. 字节集_ROT13 (A)
  13. 输出调试文本 (到文本 (A))


  14. .子程序 字节集_ROT13, , 公开
  15. .参数 数据, 字节集, 参考, 必须是变量

  16. 置入代码 ({ 96, 139, 69, 8, 139, 0, 139, 88, 4, 131, 192, 8, 185, 0, 0, 0, 0, 235, 55, 138, 20, 1, 128, 250, 65, 114, 5, 128, 250, 77, 118, 10, 128, 250, 97, 114, 10, 128, 250, 109, 119, 5, 128, 194, 13, 235, 23, 128, 250, 78, 114, 5, 128, 250, 90, 118, 10, 128, 250, 110, 114, 8, 128, 250, 122, 119, 3, 128, 234, 13, 136, 20, 1, 65, 59, 203, 114, 197, 97, 201, 194, 4, 0 })
  17. ' pushad
  18. ' mov eax,[ebp+8]
  19. ' mov eax,[eax]
  20. ' mov ebx,[eax+4]
  21. ' add eax,8
  22. ' mov ecx,0
  23. ' .while ecx < ebx
  24. ' mov dl,[eax+ecx]
  25. ' .if dl >=65 && dl <=77 || dl >=97 && dl <=109
  26. ' add dl,13
  27. ' .elseif dl >=78 && dl <=90 || dl>=110 && dl <=122
  28. ' sub dl,13
  29. ' .endif
  30. ' mov [eax+ecx],dl
  31. ' inc ecx
  32. ' .endw
  33. ' popad
  34. ' leave
  35. ' retn 4


复制代码

相关帖子

回复

使用道具 举报

发表于 2019-6-30 20:21:44 | 显示全部楼层

这个处理的是字节集,以前那个是文本型,不一样的。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则