更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 125|回复: 0
收起左侧

易语言置入代码检测一段文本型是否为纯数字(返回逻辑型,不支持负数、小数等其他符号)

[复制链接]
发表于 2019-7-2 11:06:02 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (是否为数字 (“1234567”))
  9. 输出调试文本 (是否为数字 (“0123456789”))
  10. 输出调试文本 (是否为数字 (“123a456”))
  11. 输出调试文本 (是否为数字 (“123”))
  12. 输出调试文本 (是否为数字 (“”))
  13. 输出调试文本 (是否为数字 (“1e+2”))




  14. .子程序 是否为数字, 逻辑型, 公开, 检测一段文本是否为纯阿拉伯数字(不支持负数、小数等其他符号)
  15. .参数 数字文本, 文本型

  16. 置入代码 ({ 83, 81, 82, 184, 1, 0, 0, 0, 139, 85, 8, 139, 10, 139, 18, 138, 26, 10, 219, 117, 4, 235, 22, 235, 17, 128, 251, 48, 114, 5, 128, 251, 59, 118, 7, 184, 0, 0, 0, 0, 235, 3, 66, 235, 226, 59, 209, 117, 5, 184, 0, 0, 0, 0, 90, 89, 91, 201, 194, 4, 0 })
  17. ' push ebx
  18. ' push ecx
  19. ' push edx
  20. ' mov eax,1
  21. ' mov edx,[ebp+8]
  22. ' mov ecx,[edx]
  23. ' mov edx,[edx]
  24. ' START:
  25. ' mov bl,[edx]
  26. ' .if bl == 0
  27. ' jmp ASM_END
  28. ' .elseif bl < 48 || bl > 59
  29. ' mov eax,0
  30. ' jmp ASM_END
  31. ' .endif
  32. ' inc edx
  33. ' JMP START
  34. ' ASM_END:
  35. ' .if edx == ecx
  36. ' mov eax,0
  37. ' .endif
  38. ' pop edx
  39. ' pop ecx
  40. ' pop ebx
  41. ' leave
  42. ' retn 4

  43. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则