免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 60|回复: 0
收起左侧

易语言置入代码 取文本数据地址() / 置文本数据地址 (文本型字符串数据指针读写程序)

[复制链接]
发表于 2019-7-8 11:09:42 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 文本, 文本型
  9. .局部变量 字节集, 字节集
  10. .局部变量 指针, 整数型

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  12. 文本 = “文本”
  13. 输出调试文本 (文本)
  14. 字节集 = 到字节集 (“Hello World! 中文测试”) + { 0 }


  15. 置文本数据地址 (文本, 取变量数据地址 (字节集))
  16. 输出调试文本 (文本)

  17. 输出调试文本 (取文本数据地址 (文本))
  18. 文本 = “Test”
  19. 指针 = 取文本数据地址 (文本)
  20. 输出调试文本 (指针, 指针到文本 (指针))

  21. .子程序 置文本数据地址, , 公开
  22. .参数 文本, 文本型, 参考, 必须为变量
  23. .参数 地址, 整数型

  24. 置入代码 ({ 139, 69, 8, 139, 85, 12, 137, 16, 201, 194, 8, 0 })
  25. ' mov eax,[ebp+8]
  26. ' mov edx,[ebp+12]
  27. ' mov [eax],edx
  28. ' leave
  29. ' retn 8


  30. .子程序 取文本数据地址, 整数型, 公开
  31. .参数 文本, 文本型

  32. 置入代码 ({ 139, 69, 8, 139, 0, 201, 194, 4, 0 })
  33. ' mov eax,[ebp+8]
  34. ' mov eax,[eax]
  35. ' leave
  36. ' retn 4
  37. 返回 (0)

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-18 06:01, 3.227.233.55 , Processed in 0.495002 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表