免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 46|回复: 0
收起左侧

易语言置入代码文本型字符串数组操作例程:访问一个数组(可指定越界返回值,返回文本型)

[复制链接]
发表于 2019-7-8 11:06:41 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A, 文本型, , "0"

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. A = { “Hello World!中文测试”, “Test123”, “中文测试”, “易语言置入代码测试” }
  10. 输出调试文本 (文本数组查询 (A, -1, “访问越界”))
  11. 输出调试文本 (文本数组查询 (A, 0, “访问越界”))
  12. 输出调试文本 (文本数组查询 (A, 1, “访问越界”))
  13. 输出调试文本 (文本数组查询 (A, 2, “访问越界”))
  14. 输出调试文本 (文本数组查询 (A, 3, “访问越界”))
  15. 输出调试文本 (文本数组查询 (A, 4, “访问越界”))
  16. 输出调试文本 (文本数组查询 (A, 5, ))





  17. .子程序 文本数组查询, 文本型, 公开, 访问一个文本型数组,返回文本型
  18. .参数 文本数组, 文本型, 数组, 欲访问的文本数组
  19. .参数 下标, 整数型, , 下标从0开始
  20. .参数 越界返回文本, 文本型, 可空, 下标小于0或大于等于数组成员数返回该文本

  21. 置入代码 ({ 83, 139, 69, 8, 139, 93, 12, 139, 0, 59, 88, 4, 115, 5, 131, 251, 0, 115, 7, 139, 69, 16, 139, 0, 235, 6, 131, 192, 8, 139, 4, 152, 91, 201, 194, 12, 0 })
  22. ' push ebx
  23. ' mov eax,[ebp+8]
  24. ' mov ebx,[ebp+12]
  25. ' mov eax,[eax]
  26. ' .if ebx >= [eax+4] || ebx < 0
  27. ' mov eax,[ebp+16]
  28. ' mov eax,[eax]
  29. ' jmp ASM_END
  30. ' .endif
  31. ' add eax,8
  32. ' mov eax,[eax+ebx*4]
  33. ' ASM_END:
  34. ' pop ebx
  35. ' leave
  36. ' retn 12

  37. 返回 (“”)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-18 06:18, 3.227.233.55 , Processed in 0.359800 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表