免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 12|回复: 0
收起左侧

易语言汇编置入代码实现逻辑型数组变量的 取反/not/非运算操作 (执行后真变假,假变真)

[复制链接]
发表于 2019-7-8 22:46:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 逻辑型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 置随机数种子 ()
  11. .计次循环首 (64, )
  12.     加入成员 (A, 取随机数 (0, 1) = 1)
  13. .计次循环尾 ()

  14. 逻辑型数组取反 (A)
  15. 调试输出 (A)
  16. 逻辑型数组_取反 (A)
  17. 调试输出 (A)


  18. .子程序 逻辑型数组取反, , 公开
  19. .参数 逻辑型数组, 逻辑型, 参考 数组, 必须为变量

  20. 置入代码 ({ 96, 139, 69, 8, 139, 0, 139, 80, 4, 131, 192, 8, 187, 0, 0, 0, 0, 235, 10, 139, 12, 152, 131, 241, 1, 137, 12, 152, 67, 59, 218, 114, 242, 97, 201, 194, 4, 0 })
  21. ' pusha
  22. ' mov eax,[ebp+8]
  23. ' mov eax,[eax]
  24. ' mov edx,[eax+4]
  25. ' add eax,8
  26. ' mov ebx,0
  27. ' .while ebx < edx
  28. ' mov ecx,[eax+ebx*4]
  29. ' xor ecx,1
  30. ' mov [eax+ebx*4],ecx
  31. ' inc ebx
  32. ' .endw
  33. ' popa
  34. ' leave
  35. ' retn 4

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 01:06, 107.23.37.199 , Processed in 0.078125 second(s), 28 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表