免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 18|回复: 2
收起左侧

易语言置入代码返回小数型/双精度小数型 1.#INF、-1.#INF (真为正溢出,假为负溢出值)

[复制链接]
发表于 2019-7-8 23:58:24 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (小数型_溢出 (真))
  9. 输出调试文本 (小数型_溢出 (假))
  10. 输出调试文本 (双精度小数型_溢出 (真))
  11. 输出调试文本 (双精度小数型_溢出 (假))



  12. .子程序 小数型_溢出, 小数型, 公开, 返回 1.#INF(正溢出) 或 -1.#INF (负溢出)
  13. .参数 正负, 逻辑型, , 真为正数,假为负数

  14. 置入代码 ({ 139, 69, 8, 131, 248, 1, 117, 7, 184, 0, 0, 128, 127, 235, 5, 184, 0, 0, 128, 255, 201, 194, 4, 0 })
  15. ' mov eax,[ebp+8]
  16. ' .if eax == 1
  17. ' mov eax,2139095040
  18. ' .else
  19. ' mov eax,-8388608
  20. ' .endif
  21. ' leave
  22. ' retn 4
  23. 返回 (0)

  24. .子程序 双精度小数型_溢出, 双精度小数型, 公开, 返回 1.#INF(正溢出) 或 -1.#INF (负溢出)
  25. .参数 正负, 逻辑型, , 真为正数,假为负数

  26. 置入代码 ({ 139, 69, 8, 11, 192, 117, 7, 186, 0, 0, 240, 255, 235, 7, 51, 192, 186, 0, 0, 240, 127, 201, 194, 4, 0 })
  27. ' mov eax,[ebp+8]
  28. ' .if eax == 0
  29. ' mov edx,-1048576
  30. ' .else
  31. ' xor eax,eax
  32. ' mov edx,2146435072
  33. ' .endif
  34. ' leave
  35. ' retn 4
  36. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:05, 107.23.37.199 , Processed in 0.101567 second(s), 44 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表