免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 22|回复: 3
收起左侧

易语言置入代码智能去除文本型路径字符串末尾所有的斜杠、反斜杠 (没有斜杠不去除)

[复制链接]
发表于 2019-7-9 10:37:47 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 路径, 文本型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 路径 = “Test/\”
  10. 输出调试文本 (末尾去斜杠 (路径))
  11. 输出调试文本 (路径)
  12. 路径 = “Test”
  13. 输出调试文本 (末尾去斜杠 (路径))
  14. 输出调试文本 (路径)
  15. 路径 = “C:\Windows\”
  16. 输出调试文本 (末尾去斜杠 (路径))
  17. 输出调试文本 (路径)
  18. 路径 = “http://”
  19. 输出调试文本 (末尾去斜杠 (路径))
  20. 输出调试文本 (路径)
  21. 路径 = “D://////////\\\///Test///\\\”
  22. 输出调试文本 (末尾去斜杠 (路径))
  23. 输出调试文本 (路径)



  24. .子程序 末尾去斜杠, 整数型, 公开, 可去除文本末尾所有的斜杠(反斜杠) 去除几个斜杠返回几
  25. .参数 路径, 文本型, 参考, 必须为变量 本程序不检测空格,处理前注意首尾空格

  26. 置入代码 ({ 82, 83, 51, 192, 183, 0, 139, 85, 8, 139, 18, 138, 26, 10, 219, 117, 32, 138, 90, 255, 128, 251, 47, 116, 5, 128, 251, 92, 117, 8, 183, 1, 64, 179, 0, 136, 90, 255, 128, 255, 1, 117, 4, 235, 215, 235, 2, 235, 3, 66, 235, 215, 91, 90, 201, 194, 4, 0 })
  27. ' push edx
  28. ' push ebx
  29. ' xor eax,eax
  30. ' ASM_START:
  31. ' mov bh,0
  32. ' mov edx,[ebp+8]
  33. ' mov edx,[edx]
  34. ' TEXT_LOOP:
  35. ' mov bl,[edx]
  36. ' .if bl == 0
  37. ' mov bl,[edx-1]
  38. ' .if bl == '/' || bl == '\'
  39. ' mov bh,1
  40. ' inc eax
  41. ' mov bl,0
  42. ' mov [edx-1],bl
  43. ' .endif
  44. ' .if bh == 1
  45. ' jmp ASM_START
  46. ' .elseif
  47. ' jmp ASM_END
  48. ' .endif
  49. ' .endif
  50. ' inc edx
  51. ' jmp TEXT_LOOP
  52. ' ASM_END:
  53. ' pop ebx
  54. ' pop edx
  55. ' leave
  56. ' retn 4
  57. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:52, 107.23.37.199 , Processed in 0.078128 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表