免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 15|回复: 4
收起左侧

易语言汇编置入代码比较两个长整数型数组内容是否一致(解决易语言不支持数组等于比较)

[复制链接]
发表于 6 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1, , ,

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A, 长整数型, , "1"
  8. .局部变量 B, 长整数型, , "1"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A [1] = 取字节集数据 ({ 1, 2, 3, 4, 5, 6, 7, 8 }, 4, )
  11. B [1] = 取字节集数据 ({ 1, 2, 3, 4, 5, 6, 7, 8 }, 4, )

  12. 输出调试文本 (长整数型数组等于 (A, B))
  13. A [1] = 取字节集数据 ({ 1, 2, 3, 4, 5, 6, 7, 8 }, 4, )
  14. B [1] = 取字节集数据 ({ 2, 2, 3, 4, 5, 6, 7, 8 }, 4, )

  15. 输出调试文本 (长整数型数组等于 (A, B))
  16. A = { 1, 2, 3, 4, 5 }
  17. B = { 1, 2, 3, 4, 5, 6 }

  18. 输出调试文本 (长整数型数组等于 (A, B))

  19. A = {  }
  20. B = {  }
  21. 输出调试文本 (长整数型数组等于 (A, B))
  22. A = { 1.234567890123e+015, 1.124235237409e+015, 45425, -1.232131231231e+014 }

  23. B = { 1.234567890123e+015, 1.124235237409e+015, 45425, -1.232131231231e+014 }

  24. 输出调试文本 (长整数型数组等于 (A, B))


  25. .子程序 长整数型数组等于, 逻辑型, 公开, 被比较数组与比较数组的成员数、值相同时返回真,否则返回假 (解决易语言不支持数组比较)
  26. .参数 被比较值, 长整数型, 数组
  27. .参数 比较值, 长整数型, 数组

  28. 置入代码 ({ 83, 81, 82, 86, 87, 139, 69, 8, 139, 0, 139, 88, 4, 139, 77, 12, 139, 9, 139, 81, 4, 131, 192, 8, 131, 193, 8, 59, 218, 116, 4, 51, 192, 235, 40, 51, 210, 235, 27, 139, 52, 208, 139, 124, 208, 4, 51, 52, 209, 51, 124, 209, 4, 11, 246, 117, 4, 11, 255, 116, 4, 51, 192, 235, 10, 66, 59, 211, 114, 225, 184, 1, 0, 0, 0, 95, 94, 90, 89, 91, 201, 194, 8, 0 })
  29. ' push ebx
  30. ' push ecx
  31. ' push edx
  32. ' push esi
  33. ' push edi
  34. ' mov eax,[ebp+8]
  35. ' mov eax,[eax]
  36. ' mov ebx,[eax+4]
  37. ' mov ecx,[ebp+12]
  38. ' mov ecx,[ecx]
  39. ' mov edx,[ecx+4]
  40. ' add eax,8
  41. ' add ecx,8
  42. ' .if ebx != edx
  43. ' xor eax,eax
  44. ' jmp ASM_END
  45. ' .endif
  46. ' xor edx,edx
  47. ' .while edx<ebx
  48. ' mov esi,[eax+edx*8]
  49. ' mov edi,[eax+edx*8+4]
  50. ' xor esi,[ecx+edx*8]
  51. ' xor edi,[ecx+edx*8+4]
  52. ' .if esi != 0 || edi != 0
  53. ' xor eax,eax
  54. ' jmp ASM_END
  55. ' .endif
  56. ' inc edx
  57. ' .endw
  58. ' mov eax,1
  59. ' ASM_END:
  60. ' pop edi
  61. ' pop esi
  62. ' pop edx
  63. ' pop ecx
  64. ' pop ebx
  65. ' leave
  66. ' retn 8

  67. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:33, 107.23.37.199 , Processed in 0.093753 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表