更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 139|回复: 1
收起左侧

易语言汇编置入代码实现整数型数组的极速按位取反(not)非运算处理操作 (无返回值)

[复制链接]
发表于 2019-7-12 21:00:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1, , ,

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 整数型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = { 0, 1, 2, 3, 4, 5 }
  11. 调试输出 (A)
  12. 整数型数组_位取反 (A)
  13. 调试输出 (A)
  14. 整数型数组_位取反 (A)
  15. 调试输出 (A)
  16. 整数型数组_位取反 (A)






  17. .子程序 整数型数组_位取反, , 公开
  18. .参数 整数型数组, 整数型, 参考 数组

  19. 置入代码 ({ 96, 139, 69, 8, 139, 0, 139, 80, 4, 131, 192, 8, 187, 0, 0, 0, 0, 235, 9, 139, 12, 152, 247, 209, 137, 12, 152, 67, 59, 218, 114, 243, 97, 201, 194, 4, 0 })
  20. ' pusha
  21. ' mov eax,[ebp+8]
  22. ' mov eax,[eax]
  23. ' mov edx,[eax+4]
  24. ' add eax,8
  25. ' mov ebx,0
  26. ' .while ebx < edx
  27. ' mov ecx,[eax+ebx*4]
  28. ' not ecx
  29. ' mov [eax+ebx*4],ecx
  30. ' inc ebx
  31. ' .endw
  32. ' popa
  33. ' leave
  34. ' retn 4

复制代码

相关帖子

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则