免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 11|回复: 2
收起左侧

易语言置入代码判断字节型/短整数型/整数型/长整数型是否为0返回真,非0假(返回逻辑型)

[复制链接]
发表于 7 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (是否为零_字节型 (0))
  9. 输出调试文本 (是否为零_字节型 (1))
  10. 输出调试文本 (是否为零_字节型 (2))
  11. 输出调试文本 (是否为零_字节型 (3))

  12. 输出调试文本 (是否为零_短整数型 (0))
  13. 输出调试文本 (是否为零_短整数型 (1))
  14. 输出调试文本 (是否为零_短整数型 (-2))
  15. 输出调试文本 (是否为零_短整数型 (3))




  16. 输出调试文本 (是否为零_整数型 (0))
  17. 输出调试文本 (是否为零_整数型 (1))
  18. 输出调试文本 (是否为零_整数型 (-2))
  19. 输出调试文本 (是否为零_整数型 (3))

  20. 输出调试文本 (是否为零_长整数型 (0))
  21. 输出调试文本 (是否为零_长整数型 (1))
  22. 输出调试文本 (是否为零_长整数型 (-2))
  23. 输出调试文本 (是否为零_长整数型 (3))



  24. .子程序 是否为零_字节型, 逻辑型, 公开, 0返回真,非0返回假
  25. .参数 数值, 字节型

  26. 置入代码 ({ 138, 69, 8, 10, 192, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  27. ' mov al,[ebp+8]
  28. ' .if al == 0
  29. ' mov eax,1
  30. ' .else
  31. ' xor eax,eax
  32. ' .endif
  33. ' leave
  34. ' retn 4

  35. 返回 (假)

  36. .子程序 是否为零_短整数型, 逻辑型, 公开, 0返回真,非0返回假
  37. .参数 数值, 短整数型

  38. 置入代码 ({ 102, 139, 69, 8, 102, 11, 192, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  39. ' mov ax,[ebp+8]
  40. ' .if ax == 0
  41. ' mov eax,1
  42. ' .else
  43. ' xor eax,eax
  44. ' .endif
  45. ' leave
  46. ' retn 4
  47. 返回 (假)



  48. .子程序 是否为零_整数型, 逻辑型, 公开, 0返回真,非0返回假
  49. .参数 数值, 整数型

  50. 置入代码 ({ 139, 69, 8, 11, 192, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  51. ' mov eax,[ebp+8]
  52. ' .if eax == 0
  53. ' mov eax,1
  54. ' .else
  55. ' xor eax,eax
  56. ' .endif
  57. ' leave
  58. ' retn 4

  59. 返回 (假)


  60. .子程序 是否为零_长整数型, 逻辑型, 公开
  61. .参数 数值, 长整数型

  62. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 11, 192, 117, 11, 11, 210, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 90, 201, 194, 8, 0 })
  63. ' push edx
  64. ' mov eax,[ebp+8]
  65. ' mov edx,[ebp+12]
  66. ' .if eax == 0 && edx == 0
  67. ' mov eax,1
  68. ' .else
  69. ' xor eax,eax
  70. ' .endif
  71. ' pop edx
  72. ' leave
  73. ' retn 8
  74. 返回 (假)
复制代码
回复

使用道具 举报

腾讯云为数百万企业和开发者提供安全、稳定的云服务器、云数据库、CDN等云服务
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 00:43, 107.23.37.199 , Processed in 0.066409 second(s), 25 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表