更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 143|回复: 0
收起左侧

易语言置入代码实现判断检测字节集数组中是否有零字节的空字节集成员 (返回逻辑型)

[复制链接]
发表于 2019-7-10 12:01:31 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 字节集数组, 字节集, , "5"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 字节集数组 [1] = { 1, 2, 3 }
  11. 字节集数组 [2] = { 1, 2, 3, 4 }
  12. 字节集数组 [3] = { 1 }
  13. 字节集数组 [4] = { 234, 234, 234, 234 }
  14. 字节集数组 [5] = { 2, 2, 2, 2, 2 }
  15. 调试输出 (字节集数组)
  16. 输出调试文本 (字节集数组_是否有空字节集 (字节集数组))

  17. 字节集数组 [3] = {  }
  18. 调试输出 (字节集数组)
  19. 输出调试文本 (字节集数组_是否有空字节集 (字节集数组))
  20. 字节集数组 [3] = { 0 }
  21. 调试输出 (字节集数组)
  22. 输出调试文本 (字节集数组_是否有空字节集 (字节集数组))



  23. .子程序 字节集数组_是否有空字节集, 逻辑型, 公开, 检测到字节集数组中存在零字节的成员返回真,否则返回假
  24. .参数 字节集数组, 字节集, 数组

  25. 置入代码 ({ 83, 81, 82, 139, 69, 8, 139, 24, 139, 67, 4, 131, 195, 8, 51, 201, 235, 18, 139, 20, 139, 139, 82, 4, 11, 210, 117, 7, 184, 1, 0, 0, 0, 235, 7, 65, 59, 200, 114, 234, 51, 192, 90, 89, 91, 201, 194, 4, 0 })
  26. ' push ebx
  27. ' push ecx
  28. ' push edx
  29. ' mov eax,[ebp+8]
  30. ' mov ebx,[eax]
  31. ' mov eax,[ebx+4]
  32. ' add ebx,8
  33. ' xor ecx,ecx
  34. ' .while ecx<eax
  35. ' mov edx,[ebx+ecx*4]
  36. ' mov edx,[edx+4]
  37. ' .if edx == 0
  38. ' mov eax,1
  39. ' jmp ASM_END
  40. ' .endif
  41. ' inc ecx
  42. ' .endw
  43. ' xor eax,eax
  44. ' ASM_END:
  45. ' pop edx
  46. ' pop ecx
  47. ' pop ebx
  48. ' leave
  49. ' retn 4
  50. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则