更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言置入代码实现长整数型、双精度小数型、日期时间型数组填充为指定值 (无返回值)

[复制链接]
查看106 | 回复0 | 2019-7-23 10:27:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 双精度小数型, , "0"
  9. .局部变量 B, 长整数型, , "0"
  10. .局部变量 C, 日期时间型, , "0"

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  12. 重定义数组 (A, 假, 100)
  13. 重定义数组 (B, 假, 100)
  14. 重定义数组 (C, 假, 100)
  15. 双精度小数型数组_填充 (A, #pi)
  16. 调试输出 (A)
  17. 长整数型数组_填充 (B, 1.234567890123e+014)
  18. 调试输出 (B)
  19. 日期时间型数组_填充 (C, 取现行时间 ())
  20. 调试输出 (C)

  21. .子程序 双精度小数型数组_填充, , 公开
  22. .参数 数组, 双精度小数型, 参考 数组
  23. .参数 填充值, 双精度小数型

  24. 置入代码 ({ 96, 139, 93, 8, 139, 27, 139, 75, 4, 131, 195, 8, 139, 69, 12, 139, 85, 16, 86, 51, 246, 235, 8, 137, 4, 243, 137, 84, 243, 4, 70, 59, 241, 114, 244, 94, 97, 201, 194, 12, 0 })
  25. ' pusha
  26. ' mov ebx,[ebp+8]
  27. ' mov ebx,[ebx]
  28. ' mov ecx,[ebx+4]
  29. ' add ebx,8
  30. ' mov eax,[ebp+12]
  31. ' mov edx,[ebp+16]
  32. ' push esi
  33. ' xor esi,esi
  34. ' .while esi<ecx
  35. ' mov [ebx+esi*8],eax
  36. ' mov [ebx+esi*8+4],edx
  37. ' inc esi
  38. ' .endw
  39. ' pop esi
  40. ' popa
  41. ' leave
  42. ' retn 12



  43. .子程序 长整数型数组_填充, , 公开
  44. .参数 数组, 长整数型, 参考 数组
  45. .参数 填充值, 长整数型

  46. 置入代码 ({ 96, 139, 93, 8, 139, 27, 139, 75, 4, 131, 195, 8, 139, 69, 12, 139, 85, 16, 86, 51, 246, 235, 8, 137, 4, 243, 137, 84, 243, 4, 70, 59, 241, 114, 244, 94, 97, 201, 194, 12, 0 })
  47. ' pusha
  48. ' mov ebx,[ebp+8]
  49. ' mov ebx,[ebx]
  50. ' mov ecx,[ebx+4]
  51. ' add ebx,8
  52. ' mov eax,[ebp+12]
  53. ' mov edx,[ebp+16]
  54. ' push esi
  55. ' xor esi,esi
  56. ' .while esi<ecx
  57. ' mov [ebx+esi*8],eax
  58. ' mov [ebx+esi*8+4],edx
  59. ' inc esi
  60. ' .endw
  61. ' pop esi
  62. ' popa
  63. ' leave
  64. ' retn 12



  65. .子程序 日期时间型数组_填充, , 公开
  66. .参数 数组, 日期时间型, 参考 数组
  67. .参数 填充值, 日期时间型

  68. 置入代码 ({ 96, 139, 93, 8, 139, 27, 139, 75, 4, 131, 195, 8, 139, 69, 12, 139, 85, 16, 86, 51, 246, 235, 8, 137, 4, 243, 137, 84, 243, 4, 70, 59, 241, 114, 244, 94, 97, 201, 194, 12, 0 })
  69. ' pusha
  70. ' mov ebx,[ebp+8]
  71. ' mov ebx,[ebx]
  72. ' mov ecx,[ebx+4]
  73. ' add ebx,8
  74. ' mov eax,[ebp+12]
  75. ' mov edx,[ebp+16]
  76. ' push esi
  77. ' xor esi,esi
  78. ' .while esi<ecx
  79. ' mov [ebx+esi*8],eax
  80. ' mov [ebx+esi*8+4],edx
  81. ' inc esi
  82. ' .endw
  83. ' pop esi
  84. ' popa
  85. ' leave
  86. ' retn 12

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则