免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 61|回复: 0
收起左侧

易语言MASM汇编置入代码实现16位短整数型数组所有成员填充为指定短整数值 (无返回值)

[复制链接]
发表于 2019-7-23 18:45:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 短整数型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = { 1, 2, 3, 4, 5 }
  11. 调试输出 (A)
  12. 短整数型数组_填充 (A, 12345)
  13. 调试输出 (A)
  14. 短整数型数组_填充 (A, -1)
  15. 调试输出 (A)
  16. 短整数型数组_填充 (A, -10000)
  17. 调试输出 (A)


  18. .子程序 短整数型数组_填充, , 公开
  19. .参数 数组, 短整数型, 参考 数组, 必须为数组变量
  20. .参数 值, 短整数型

  21. 置入代码 ({ 96, 139, 69, 8, 102, 139, 85, 12, 139, 0, 139, 88, 4, 131, 192, 8, 51, 201, 235, 5, 102, 137, 20, 72, 65, 59, 203, 114, 247, 97, 201, 194, 8, 0 })
  22. ' pusha
  23. ' mov eax,[ebp+8]
  24. ' mov dx,[ebp+12]
  25. ' mov eax,[eax]
  26. ' mov ebx,[eax+4]
  27. ' add eax,8
  28. ' xor ecx,ecx
  29. ' .while ecx<ebx
  30. ' mov [eax+ecx*2],dx
  31. ' inc ecx
  32. ' .endw
  33. ' popa
  34. ' leave
  35. ' retn 8

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则