免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 45|回复: 0
收起左侧

易语言MASM汇编置入代码小数型与整数型强制位与、位或、位异或逻辑运算 (返回整数型)

[复制链接]
发表于 2019-7-26 07:53:27 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1, , , 使用本模块应遵守IEEE754协议规定,否则浮点数会出现异常

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  9. 调试输出 (小数型与整数型_位异或_返回整数型 (1.23, -2147483648))

  10. .子程序 小数型与整数型_位与_返回整数型, 整数型, 公开
  11. .参数 值A, 小数型
  12. .参数 值B, 整数型

  13. 置入代码 ({ 139, 69, 8, 35, 69, 12, 201, 194, 8, 0 })
  14. ' mov eax,[ebp+8]
  15. ' and eax,[ebp+12]
  16. ' leave
  17. ' retn 8

  18. 返回 (0)


  19. .子程序 小数型与整数型_位或_返回整数型, 整数型, 公开
  20. .参数 值A, 小数型
  21. .参数 值B, 整数型

  22. 置入代码 ({ 139, 69, 8, 11, 69, 12, 201, 194, 8, 0 })
  23. ' mov eax,[ebp+8]
  24. ' or eax,[ebp+12]
  25. ' leave
  26. ' retn 8
  27. 返回 (0)

  28. .子程序 小数型与整数型_位异或_返回整数型, 整数型, 公开
  29. .参数 值A, 小数型
  30. .参数 值B, 整数型

  31. 置入代码 ({ 139, 69, 8, 51, 69, 12, 201, 194, 8, 0 })
  32. ' mov eax,[ebp+8]
  33. ' xor eax,[ebp+12]
  34. ' leave
  35. ' retn 8

  36. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 01:14, 100.26.182.28 , Processed in 0.671603 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表