免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 51|回复: 1
收起左侧

易语言MASM置入代码版 取字节集内短整数() / 置字节集内短整数() (带是否反转字节序)

[复制链接]
发表于 2019-7-25 10:01:55 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 字节集

  9. A = { 1, 2, 3, 4, 5, 6 }
  10. 置字节集内短整数 (A, 0, 12345, 假)
  11. 调试输出 (取字节集内短整数 (A, 0))
  12. 调试输出 (A, 取字节集数据 (A, 2, 1))



  13. .子程序 取字节集内短整数, 短整数型, 公开, 功能与核心库自带 取字节集内整数() 相同
  14. .参数 待处理的字节集, 字节集
  15. .参数 欲获取短整数所处偏移, 整数型, , 严禁负数或越界否则会取出错误的数据
  16. .参数 是否反转字节序, 逻辑型, 可空

  17. 置入代码 ({ 81, 86, 87, 139, 125, 8, 139, 63, 131, 199, 8, 139, 117, 12, 51, 192, 102, 139, 4, 62, 138, 77, 16, 128, 249, 1, 117, 2, 134, 196, 95, 94, 89, 201, 194, 12, 0 })
  18. ' push ecx
  19. ' push esi
  20. ' push edi
  21. ' mov edi,[ebp+8]
  22. ' mov edi,[edi]
  23. ' add edi,8
  24. ' mov esi,[ebp+12]
  25. ' xor eax,eax
  26. ' mov ax,[edi+esi]
  27. ' mov cl,[ebp+16]
  28. ' .if cl == 1
  29. ' xchg al,ah
  30. ' .endif
  31. ' pop edi
  32. ' pop esi
  33. ' pop ecx
  34. ' leave
  35. ' retn 12

  36. 返回 (0)

  37. .子程序 置字节集内短整数, , 公开, 功能与核心库自带 置字节集内整数 () 相同
  38. .参数 待处理的字节集, 字节集, , 必须为字节集变量
  39. .参数 欲设置短整数所处偏移, 整数型, , 严禁负数或越界否则会造成程序异常
  40. .参数 欲设置的短整数值, 短整数型
  41. .参数 是否反转字节序, 逻辑型, 可空

  42. 置入代码 ({ 81, 86, 87, 80, 139, 117, 8, 139, 54, 131, 198, 8, 139, 125, 12, 51, 192, 102, 139, 69, 16, 138, 77, 20, 128, 249, 1, 117, 2, 134, 196, 102, 137, 4, 55, 88, 95, 94, 89, 201, 194, 16, 0 })
  43. ' push ecx
  44. ' push esi
  45. ' push edi
  46. ' push eax
  47. ' mov esi,[ebp+8]
  48. ' mov esi,[esi]
  49. ' add esi,8
  50. ' mov edi,[ebp+12]
  51. ' xor eax,eax
  52. ' mov ax,[ebp+16]
  53. ' mov cl,[ebp+20]
  54. ' .if cl == 1
  55. ' xchg al,ah
  56. ' .endif
  57. ' mov [esi+edi],ax
  58. ' pop eax
  59. ' pop edi
  60. ' pop esi
  61. ' pop ecx
  62. ' leave
  63. ' retn 16

复制代码

相关帖子

回复

使用道具 举报

腾讯云服务器安全可靠高性能,多种配置供您选择
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 00:46, 100.26.182.28 , Processed in 0.381401 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表