免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 46|回复: 0
收起左侧

易语言MASM置入代码实现双精度小数型(3.141593)与长整数型(4614256656551843652)互转

[复制链接]
发表于 2019-7-26 08:24:52 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 长整数型

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = 双精度小数型到长整数型 (#pi)
  11. 调试输出 (A, 长整数型到双精度小数型 (A))

  12. .子程序 双精度小数型到长整数型, 长整数型, 公开, 提供 双精度小数型(3.141593) 将返回 长整数型(4614256656551843652)
  13. .参数 值, 双精度小数型

  14. 置入代码 ({ 139, 69, 8, 139, 85, 12, 201, 194, 8, 0 })
  15. ' mov eax,[ebp+8]
  16. ' mov edx,[ebp+12]
  17. ' leave
  18. ' retn 8
  19. 返回 (0)

  20. .子程序 长整数型到双精度小数型, 双精度小数型, 公开, 与 双精度小数型到长整数型() 过程相反
  21. .参数 值, 长整数型, , 转换前请注意大小端,错误的数据将会造成浮点异常

  22. 置入代码 ({ 139, 69, 8, 139, 85, 12, 201, 194, 8, 0 })
  23. ' mov eax,[ebp+8]
  24. ' mov edx,[ebp+12]
  25. ' leave
  26. ' retn 8
  27. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 00:35, 100.26.182.28 , Processed in 0.955002 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表